Phone not registered for SMS notification service?? HELP

Discussion in 'iPhone' started by trlyka, Oct 11, 2012.

  1. trlyka macrumors 6502a

    trlyka

    Joined:
    Dec 26, 2011
    #1
    I have my Xfinity connect App that I mainly only use for push notifications for when someone calls my home, I can see it come up on my cell. There is a new feature for receiving text messages thru Comcast services, but when I try to turn the feature on, I get the pop up 'Your phone is not registered or SMS notification service'. I just got the phone yesterday. It's the 5. I didn't change any settings for SMS. It is turned on in my Text message option. Is there another place I need to look for this setting?

    Thanks
     
  2. trlyka thread starter macrumors 6502a

    trlyka

    Joined:
    Dec 26, 2011
    #2
    I called AT&T and we did a factory reset and re downloaded the app. I was able to turn on the text msg feature where before I was getting that SMS error msg. Also, prior to resetting, I wasn't getting the caller ID pop. I restored from backup and the caller ID pop is working, but now I can't turn on the text message option again and I get the same msg. It all works fine on my Moms 5 that I just set up tonight. I even uninstalled and reinstalled the app a few times.
     
  3. trlyka thread starter macrumors 6502a

    trlyka

    Joined:
    Dec 26, 2011
    #3
    Solution

    I had called Comcast and they opened a ticket. I had gone to the Apple store to see if they knew anything. Everyone...AT&T, Apple and Comcast were stumped. While I was at Apple, I had my laptop and went on a live chat with a Comcast agent. This agent told me that only one user per land line phone number could receive the text message option. This solved it. As soon as I turned off the feature from my Moms iPhone, mine was able to work.

    The odd thing that didn't occur to me, is that we each have a home phone and different user ID's, so we should both be able to use this feature. I'll have to address this when I have more time. It doesn't make any sense that they would only allow one user, but it did resolve the issue of the error msg I was getting.
     

Share This Page