Photos moved to external drive - Still showing in internal

lympero

macrumors 6502a
Original poster
Sep 1, 2008
792
420
Arta, Greece
Ok here is my problem. I have an external samsung ssd and i have moved and linked my photos folder to this drive and i have set my mac to download originals.

Screen Shot 2017-04-14 at 00.49.00.png


If i go to About this mac - storage it says that i have 70gb Photos in my internal hdd.

Screen Shot 2017-04-14 at 00.52.26.png


If i search my internal HDD there is no photos library and the photo library in my external drive is 65GB. What is going on here? Any help?
 

Yahooligan

macrumors 6502a
Aug 7, 2011
965
113
Illinois
Definitely a bug. I'd ignore that usage info and if you want to find out where the big space users really are then give DaisyDisk a try.
 

KoolAid-Drink

macrumors 65816
Sep 18, 2013
1,343
322
USA
I have the same issue on my MBP running Sierra. I divided my SSD in two partitions – one for the OS, and another for my data. I have my Photos library on the data partition, but under Usage, it shows the Photo library on the OS partition. Definitely a bug.

I also recommend GrandPerspective – free. http://grandperspectiv.sourceforge.net/
 

DHA

macrumors member
Dec 14, 2014
42
10
Same issue for me, except it thinks my iTunes library is on my internal drive when it's located externally.

If you shut down, disconnect the external drive then restart it will have the correct usage stats. But once you connect the external drive the issue re-occurs. This has been present in the current (12.4) and previous version of Sierra.