photoshop 7.0 won't load!!

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by flan0000, Oct 26, 2003.

  1. flan0000 macrumors newbie

    Oct 26, 2003
    cardfiff, wales
    Hi there,

    did a clean install of Panther, i have oS 9.2.1 also, did a clean install of all my software - all runs fine except photoshop 7.0, which keeps quiting out just before it loads.

    Re-start in OS9 and run it and it works fine, run classic in X and i get the same - quits out.....very strange!

    any ideas....any body had the same??


  2. yamadataro macrumors 6502

    My Photoshop 7 is woking just fine on Panther. It's a Japanese edition though...
  3. foniks2020 macrumors regular

    Apr 19, 2002
    Try repairing permissions?

    PS 7 works fine for me.

    I didn't do a fresh install though. I did do a clean erase and install of Panther but I just copied my apps from my backup, including the relevant Adobe application support folders (in "/Library/Application Support/Adobe" and "~/Library/Application Support/Adobe"). I did not copy the preference files for fear of corrupted prefs.
  4. sweetandsour macrumors newbie

    Oct 26, 2003
    London, UK
    photoshop 7 wont launch

    I have the same problem.
    Installed 10.3 yesterday (update from 10.2.8, not clean install)
    Now neither photoshop 7 or illustrator 10 will launch. same happens, quits during startup.
    Have repaired permissions but still the same problems. All other apps ok.

    Anyone got any ideas?
  5. flan0000 thread starter macrumors newbie

    Oct 26, 2003
    cardfiff, wales
    how do i repair permissions?

    i've tried a clean install again, same result - tried updating to Photoshop 7.01 - still quits out..... strange thing is ImageReady works fine.

    going made with this - been using ImageReady all weekend which is ok but not ideal.

    Any ideas???:mad:
  6. sweetandsour macrumors newbie

    Oct 26, 2003
    London, UK
    to repair permissions use disk utility which is in applications/utilities
    Although this hasnt helped me.

    I have NO IDEA what the problem is.

  7. snickelfritz macrumors 65816


    Oct 24, 2003
    Tucson AZ
    Have you tried trashing the prefs?
    Worked well for earlier systems.

    BTW, Macromedia StudioMX and Photoshop7 are working fine here.
    I used the default "upgrade" installation of Panther. (after repairing HDD and permissions, and repaired permissions afterward as well)
  8. sweetandsour macrumors newbie

    Oct 26, 2003
    London, UK
    thanks, but yes have tried chucking the prefs away and still no PS or Illus.

  9. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    PANTHER - Apps that crash = MS Office, Adobe...

    PANTHER runs harmoniously with Adobe Photoshop and Illustrator on both my iBook 700 and G4 dual 1 GHz :D

    However, I had a hard time Installing Panther on my iBook for several hours because it kept demanding a RESTART instead of an INSTALL. Grrrr :mad:
    I kept using TechTools, Norton, and Disk Utility (permissions) until it worked. Once it finally took, everything has been all right. ;)

    Panther on iBook is marginally faster, but on my
    G4 dual 1 GHz - it is SCREAMING FAST !!! Like it was a G5. :D

    My impathy with your Adobe crashing comes from a problem I created :mad: AFTER installing PANTHER, by re-installing UnSANITY software's latest versions of Apple Menu / Labels X / Window Shade (not compatible with Panther, yet). I thus created a conflict :mad: with all MS OFFICE apps (Word / Excel / Entourage / PP; but NOT Internet Explorer - different folder) which would NOT OPEN and kept crashing. :(

    SOLUTION was to:
    Un-Install all three programs (not enough) and then I needed to
    TRASH each of their Preference files
    (Users:Me:Library:preferences:com.LabelsX.plist ...)

    1. Upgrade 0S 9 to 9.2.2 - (9.2.1 is not good enough)
    2. Repair Permissions / Owner @ Root by running (Applications: Utilities: Disk Utility) both BEFORE and AFTER installing PANTHER
    3. Back up EVERYTHING you would die over if destroyed
    4. Run 3rd party utility like TechTools or Norton to get anything Apple Disk Utility missed. Consider defragmenting the drive to really clean up the empty space.
    5. Load Panther with regular install (failing that >)
    6. Load Panther with Clean Install (if problems persist >)
    7. Load Panther by wiping disk clean, initialize disk and install Panther new
    (you have BACKED everything UP right?)
    8. #2 " Repair Permissions / Owner @ Root by running (Applications: Utilities: Disk Utility) both BEFORE and AFTER installing PANTHER"
    9. Be careful what you install in OS X - make sure that it is designed to run on PANTHER 10.3 or it is fundamental to your daily needs.
    10. Re-install any problem applications, and if that doesn't work, TRASH all that program's PREFERENCES, and reinstall anew.
    11. Ultimate solution - sell your current Mac on eBay, then invest the money in a new G5 dual 2.0 or G4 Aluminum PowerBook with Panther already loaded, and buy AppleCare as a 3-year insurance policy.
    12. Tell the rest of us in this thread what you have done that WORKS :p or that you have tried but keeps you frustrated. Grrr! :(

    Good luck, Mac. :cool:
  10. iEric macrumors 6502a

    Jun 26, 2003
    I find that Reparing Permissions works...

    What have you done Flan? Tell us ur results!
  11. pbooktebo macrumors member

    Aug 12, 2003
    SF Bay Area
    works fine

    It may not be much help to know that it worked fine for me, but at least you know it CAN work.

    I did an Archive and Install, and repaired the permissions on this Jan 2001 Powerbook 400 Mhz.
  12. flan0000 thread starter macrumors newbie

    Oct 26, 2003
    cardfiff, wales

    Repaired Permissions, Removed all Photoshop prefs, Did clean a install (x4).

    Still the same, also run Norton and Disk Warrior.

    Run Permissions before and after loading photoshop 7.0, upgraded to 7.01.

    ImageReady works fine......Now i'm losing my mind!!!


  13. sweetandsour macrumors newbie

    Oct 26, 2003
    London, UK

    Im in exactly the same situation too.
    repaired permissions, trashed prefs, clean 10.3 install, reinstall photoshop/illustrator, disk utility checks, kicked the cat, etc, etc - BUT STILL CANT LAUNCH PS or ILLUS!!!!

  14. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    Backup everything, initialize HD, install Panther fresh

    What CPU are you guys installing Panther on?

    Your situation may now require that the HD be initialized (wiping everything and starting from scratch).

    Backup everything,
    install from Panther CD 1 (hold down "C" key upon start up)
    initialize HD, wiping everything
    install Panther fresh
    reinstall applications

    Anybody else got a better idea? :(

    Although PANTHER is running fine for me as is, I'm contemplating doing what I recommend above because my Macintosh HD partition is running out of room from all the OS X stuff loaded on it - I should have made its partition much larger originally.

    I'm even thinking about doing away with partitions all together since I have physically installed 3 hard drives in my G4 dual 1GHz tower with one set setup as a fast RAID. This gives me plenty of storage and options. Recovery of DATA on a HD with partitions is much harder if it ever dies.
  15. flan0000 thread starter macrumors newbie

    Oct 26, 2003
    cardfiff, wales
    ::::: Photoshop & Illustrator Fix :::::::

    Ok, find the following folder:

    Adobe Application Support

    in here you'll find a folder called:

    Workflow, delete this folder.

    Now it should work......Did for me!

    make all cheques payable to the Mac Wizard of Cardiff.....have fun!


    ::::: Photoshop & Illustrator Fix :::::::
  16. weely macrumors newbie

    Nov 10, 2003
    photoshop cs

    Hi Guys n girls,

    I had the same prob. I'm running Panther on a powerbook g4 800 mhz. I was in deep trouble with photoshop. Imageready no prob -> photoshop no go. :mad:

    A college of my downloaded photoshop CS. I thought, i'm in a winning mood.

    ...........**** installer of Adobe quits. Pffffffffff, no news. Then i repaired permissions on my powerbook en directly copied the app from the powerbook of my college. Siege! It's running.

    I suppose the problem is caused by a missing os 9 bootup volume. My college installed photoshop CS without problems, becaus he has the old os9 partition.

    That's my story.

    Greetz Weely:D :D
  17. iEric macrumors 6502a

    Jun 26, 2003
    my photoshop loads but it wont import/aquire from the scanner..damn epson..hurry up with os10.3 drivers
  18. weely macrumors newbie

    Nov 10, 2003

    I have the same prob with the Epson 3200 photoscanner. Pffffff.

  19. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    Canon CanoScan LiDE30 - scans ok in Panther

    All this talk about EPSON Scanners not working with Panther gave me pause - I had yet to scan anything on my CANON CanoScan LiDE30 since installing 10.3.

    1st I tried it using Canon's proprietary stand-alone scanning software - CanoScan Toolbox X

    2nd I tried scanning indirectly from within Photoshop 7 using Canon's Plug-in for the CanoScan LiDE30, which is a different interface from Tool Box X, but achieves essentially the same result.

    Both scans worked perfectly in Panther. Hurrah for Canon :D

    :confused: Have those with EPSON Scanners tried scanning from within Photoshop using the Epson Plug-in?
    File > Import > "Epson Scan"
    Or, does Epson provide their own proprietary stand-alone scanning software? :rolleyes:
  20. spirochete macrumors newbie

    Nov 11, 2003
    London England
    re: Photoshop won't load......

    Same experience with PS 7.0.1 ( & illustrator) and Panther....

    (noting that this is on a new 1.8 G5 delivered a few days ago and shipping with 10.2.8 - {nice one Apple!} which I 'over-wrote' with 10.3 panther).

    Tried just about everything here and more besides - no joy - 'unexpected quit' on loading.


    How?....appears to be a problem with the Classic environment in Panther (?)

    Boot from Panther CD

    Initialise HD (basic) (remembering to back up any important bits first!) (I used a single 160Gb partition)

    Clean install & re-boot

    Soft update to get 10.3.1

    Install PS from CD and this time surprise surprise, I get a message along the lines of:-

    "No valid Classic environment found, and this stage will be skipped" or words to that effect.

    Installer shoves on PS7 for OSX

    Download and add G5 patch from Adobe site


    Run PS - BINGO! - all working A O K

    A right pain I know, but it worked when nothing else would.

    So whats breaking PS in Panther that was OK in jaguar?


    Hope this helps

  21. Sedulous macrumors 68020


    Dec 10, 2002
    Did you install Photoshop in OS 9? Maybe that is it... I think instead of wiping your drive, it makes more sense to try reinstalling Photoshop 7 in OS X first... what harm could it do?
  22. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    Photoshop 7 running in Panther

    :) Glad you are up and running.
    What is your PRINTER and is it working OK?
    Have you tried your SCANNER Make/Model, yet?

    Had same experience as you with install (repeated RESTART cycle) on my G4 dual 1GHz, and same work around to success. I love PANTHER :D and I'm confident you will too.
  23. spirochete macrumors newbie

    Nov 11, 2003
    London England
    Photoshop 7 et al....

    As per above questions....

    Didn't install for OS 9 - 'cos OS9 as such doesn't exist on later machines. Photoshop installer (& same for Illustrator) clearly doesn't see the Classic environment in Panther as 'valid' and therefore installs only the OSX components. Why? I don't know, - might be / appears to be something to do with a clean install of panther rather than upgrading 10.2.x.

    When all is said and done the entire 'ground-up' rebuild took two and a bit hours - which is a lot less time than that spent trying to get it working by other means.

    Printer - using an Epson Colour 1160 & HP 990CXi - pretty much OK.

    Scanner - WAS using a UMAX powerlook II but can't get this (SCSI) to work under OSX (drivers!) - so looking for a replacement. - Pity, nice scanner :-(

    Advice /experiences gratefully received :)

    Regards to all,

  24. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    Photoshop 7 not installing in Classic

    Spirochete ,

    Classic allows us to run qualifying OS 9 programs that were not written for OS X while actually in OS X.

    If you have a program written for OS X, why would you want to downgrade it by running in OS 9 Classic?

    Were you hoping to run an OS 9 scanner Driver in Classic? The problem as I understand it is that things like "drivers" in Classic (as opposed to plug-ins) have to be OS X. Otherwise, an OS 9 driver requires that you startup using system OS 9.

    Example - a year ago, my UMAX FireWife scanner (loved it) only functioned in OS 9, but not in OS X or in Classic. No new driver from UMAX for my model...ever!

    Each time we wanted to scan using the OS 9 driver, we had to STARTUP in OS 9. This was not a major pain UNTIL I became totally OS X oriented with less and less reason to go back to OS 9. The stability and quality of Jaguar 10.2 was a death nell for OS 9.2.2. I quickly invested in Adobe and MS software upgrades to OS X.

    Feeling so comfortable in OS 10.2 (total convert), I decided to stop messing with workarounds for the UMAX FireWire and bought a very portable USB Canon LiDE30 for $79.

    I immediately TEST scanned a magazine color page using Photoshop 7 in OS 9 using first the trusty and fast UMAX and then the very slow CanoScan.

    OS 9 output from each was comparable - with the Canon quality equal to the UMAX, I was satisfied.
    OS X output on the CanoScan, which had a 10.2 driver, was NOT the same quality - it was incredibly SUPERIOR in OS X. WOW! Discussing this with my MacBuddies, I discovered they had the same experience with their scanners (all different). Arrival of OS X scanner drivers was one of the last nails in the OS 9 coffin.

    So, why would you even want to use the INFERIOR scanning engine in OS 9.2.2 if you receive noticibly SUPERIOR scans in OS X? :confused:
    Recognizing this, Adobe has obviously blocked loading Photoshop 7 or Illustrator 10 into Classic OS 9 as counter-productive and unnecessary. ;)

    Looking for a new scanner? :(
    :) Canon's thin & mobile LiDE series 30 through 90 ($80 - 200) are awesome, with the most recent versions running fast on USB 2.0. Canon's new desktop models also have equally impressive stats.
    Nov 2003 Review by PHOTOGRAPHIC Magazine of top photo (prints/negative & slide) scanners: (Note CanoScan8000F for under $300)
    ;) Epson Perfection 3200 Photo is a $399 (reg. retail) FireWire/USB scanner that reportedly compares its slide/negative scanning capability favorably to Nikon 8000 ($3,500).
  25. spirochete macrumors newbie

    Nov 11, 2003
    London England
    Ongoing Photoshop et al.......

    Hi MacRand,

    Not sure I understand the point your making, perhaps I have not made my posts clear.

    The intention always was to run PS and Illustrator in the OSX environment. The threads above show a pattern of others trying to do the same but experiencing the same problem - i.e PS7 etc crashes while loading in late versions of OSX for reasons that are not clear.

    I had wondered if this was peculiar to a G5, but this is clearly not the case.

    My point is that having tried all the alternative fixes, posted on this forum and others, nothing worked except the clean 'ground-up' install, amongst which a clue to what is going on is the Adobe installer now reports (under a 'clean' panther but NOT via the upgrade path) an "invalid version of Classic is present"

    The install continues but it is obvious that certain steps are omitted. Whatever has changed now means that the applications finally DO run under OSX - which was always the desired outcome.

    This then precipitates the question 'what is different between upgrading 10.2.8 to Panther' (breaks PS) and a ground-up straight install of 10.3 - which runs PS OK' ?

    Photoshop problem under panther therefore seems to be something to do with the 'new' embedded Classic environment - a problem seemingly set in place by the operation of the Adobe installer - but I could be wrong.

    However..........I hope this is helping others figure out what to do /try. Let the forum know if you get any results?

    Regards again,


Share This Page