Photoshop cannot open files

Discussion in 'Mac Apps and Mac App Store' started by theTelepath, Aug 12, 2004.

  1. theTelepath macrumors newbie

    Aug 12, 2004
    oh boy 10.3.5 was a nightmare.
    after doing the update, my computer wouldn't start up.
    I had to reinstall the OS from my bundled disks.

    After that, I had a multitude of problems. Most of which were solved by creating a new user and moving all my preferences and files.

    Now I still have this niggling problem:
    Photoshop cannot open files.

    When I double clicks a PSD file, Photoshop opens but the file does not open.
    If i drag a file into the photoshop icon (dock and finder), it switches to Photoshop but the file will not open.

    The only way to open the file is to use the file menu in photoshop.

    Incidentally, during the transferring of my home directory, i had numerous files that could not be copied and gave a disk error. This was not caught by the disk repair :( how come?

    oh what a nightmare!
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    Unfortunately, file problems and some volume structure problems cannot be solved by Disk Utility First Aid. They require something of the nature of Tech Tool Pro 4 or DiskWarrior.

    Often, you can run for a long time without realising that the volume structure is damaged. You simply end up with a slow startup or unusual errors.
  3. theTelepath thread starter macrumors newbie

    Aug 12, 2004
    Aye! tell me about it.
    Finally, Finder basically did the beachball thing almost constantly.
    I ought to get me a copy of DiskWarrior.
  4. MisterMe macrumors G4


    Jul 17, 2002
    DiskWarrior is great. However, the Telepath ought to run start-up in single user mode so that he can run fsck (File System Check). Upon start-up, press [Apple]-S. From the commandline, type fsck -f. To exit single-user mode, type exit. Then use Disk Utilities to repair permissions.
  5. decksnap macrumors 68040


    Apr 11, 2003
    We have had this issue on multiple systems at our office for quite some time. No photoshop files will actually open unless accessed through the menu. So whatever 10.3.5 did, the issue is not isolated to it in any way. I am all ears to anyone with a solution!
  6. dabirdwell macrumors 6502

    Sep 26, 2002
    I have had to go through the PS file browser since i"ve been using CS.

  7. rainman::|:| macrumors 603


    Feb 2, 2002
    Have you guys repaired permissions at any point during these problems? if not, that could have been your problem to begin with...

  8. theTelepath thread starter macrumors newbie

    Aug 12, 2004
    permissions were repaired at every point
  9. theTelepath thread starter macrumors newbie

    Aug 12, 2004
    deleting photoshop and then reinstalling it again from the original disks did the trick for me.
  10. Jonnie macrumors newbie

    Aug 13, 2004
    Yep, That's the trick. After an archived instal one tiny file is not copied into ur new system folder. U must copy it manually (don't know which file so i also reinstalled PS). It's a known problem at adobe's.


Share This Page