Photoshop won't allow files to be opened

Discussion in 'Mac Apps and Mac App Store' started by tek, May 16, 2004.

  1. tek macrumors regular

    Aug 23, 2003
    Well, here's my situation:

    I'm using Mac OS 10.3.3, fully patched, updated etc. and Adobe Photoshop CS

    My problem is, the only way I can get files to open in photoshop is go to File->Open. Double-clicking on PSDs does nothing, neither does dragging images/PSDs onto the photoshop icon in the dock.

    Does anyone know how to fix this? It's getting really annoying!
  2. Sparky's macrumors 6502a


    Feb 11, 2004
    A little more info would help, such as location of files, permissions, what other apps open, type of computer, ram, etc. All info would make it easier to figure out issue.
    I am home at the moment using Photoshop CS on a G3 with 10.2.8 and have no issues, while at work I use OS 10.3.3 on a G4 with ps CS and will try to attempt what you discribe, but I haven't had problems so far. Both machines have over 700mb of RAM.
    You could try a clean install of Photoshop, delete preferences, check permissions (sorry said that already) anyway, good luck, I'll try to get more info.

  3. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    Try going into the Get Info window for a PSD file (any file) and then going to the Open with: field. From the list, select Adobe Photoshop CS and then hit Change All... That could fix your problem.
  4. tek thread starter macrumors regular

    Aug 23, 2003
    i'm using a 12"pb/rev.b

    all permissions are fine, and of course i have the open with setting correct...

    what happens is that i'll click on an icon, it'll load photoshop, but photoshop won't load the file. if i drag an icon onto the photoshop dockling, it'll put photoshop in focus, but it won't load the file. i've tried a fresh install of OS X and PS.
  5. MarkDouma macrumors newbie

    May 16, 2004
    Grand Rapids, Michigan, USA
    This is caused by having installed Photoshop when you were running Jaguar, and because you did an archive and install of Panther.

    If you have your Previous Systems folder still laying around, look inside of it for the following file:

    /Library/ScriptingAdditions/Adobe Unit Types

    Move that file to your current /Library/ScriptingAdditions/ folder, and then restart your machine.

    If you no longer have the Previous Systems folder, you could download that file from (.sitx, ~ 3 KB)

    Hope this helps....
  6. tek thread starter macrumors regular

    Aug 23, 2003
    thanks for that! i'd never have worked it out otherwise!

Share This Page