PhotoStream Complications, Appreciate Help

Discussion in 'iPhone' started by memphisbeatles, Oct 19, 2012.

  1. memphisbeatles macrumors newbie

    Joined:
    Oct 19, 2012
    Location:
    Memphis, TN
    #1
    I have a question for all of your gurus, and appreciate your help!

    I am looking forward to using PhotoStream on our devices (my wife and I both have iPhone 4, share an iPad 2, and just purchased Apple TV and have not set up yet. Also have Macbook Pro with Mountain Lion).

    The problem: When I take a picture on my iPhone (or hers), the photos will show up in my iPad 2's photostream and in iPhoto on our MacBook as they should (including downloading into our iPhoto library). HOWEVER, they do NOT show up in our iPhone's photostream. It is completely empty. Scenario: I take a photo from iPhone, it will show up on iPad 2 photostream and in iPhoto, but on the original picture-taking phone's photostream or my wife's.

    I have PhotoStream enabled correctly on all of our devices (turned on/enabled, back up storage turned on), battery is way above 20%, am connected to WiFi. Doesn't make any sense to me.

    I have about 926 photos in our stream, and they all show up in iPhoto and on the iPad. ALL devices are logged in under ONE iCloud and Apple ID, too.

    Why on earth would the PhotoSTream stay empty on our iPhones but no other devices? I'm checked the settings, reset PhotoStream through iCloud, and unenabled and re-enabled PhotoStream, too.

    I'm completely at a loss! Appreciate any help if any of you have had this same issue.

    Thank you!
     
  2. mattopotamus macrumors G4

    mattopotamus

    Joined:
    Jun 12, 2012
    #2
    hmm, that does seem weird. I wish I could help, but have never tried using photostream over multiple phones. When you add a photo on your computer does it show up on either of your phones? If not, I am thinking it would be a setting on the mac that is not pushing it to your other devices.

    Sounds like everything is working good except photos being pushed from the mac to the other iphone.
     
  3. memphisbeatles thread starter macrumors newbie

    Joined:
    Oct 19, 2012
    Location:
    Memphis, TN
    #3
    Well...

    Thanks...well...I haven't imported any photos onto the mac, but I have little doubt they will show up in the stream. Everything on the Mac is running smoothly, and the iPad, which tells me that I know it CAN work correctly on the iOS devices. When I take a photo on the IPHONE, it will in fact show up in the stream on my Mac, and on my iPad, just on the IPHONE ITSELF, or my wife's. It is so insanely weird and frustrating.

    Also, same on her phone. If she takes a picture, it will show up in Mac/iPhoto/iPad, but not on her or my iphone PhotoStream. One of the main perks is I can see the photos she takes on her iPhone, on my iPhone, so that when I travel, I can keep with the PhotoStream of our little one :) I want it work correctly!
     
  4. mattopotamus macrumors G4

    mattopotamus

    Joined:
    Jun 12, 2012
    #4
    That is crazy that it shows on the mac and other devices, but not the phone itself. I guess I would try a restore. I wonder if it is an issue just b.c you have two phones sharing the same ID. The shared photostream is actually pretty good and makes sharing photos pretty easy....granted you would each need a separate stream
     
  5. vastoholic macrumors 68000

    vastoholic

    Joined:
    Jan 28, 2009
    Location:
    Tulsa, OK
    #5
    You know, this almost seems like a blessing and I wish my phone would do it. Obviously it's not a good thing that it's not appearing on your wife's phone. But having my photo's both in my camera roll and in my photostream is kind of redundant and just means I have to delete the same picture twice. It could come in handy for me at least. I've never had photostream on multiple devices either so I haven't run into this problem.
     
  6. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #6
    I could not agree more....I have 3 Macs, an iphone5 and an ipad3.....Taming photo stream can be a challenge to say the least....Throw Aperture into the mix and it gets worse...I actually turned it off for a while, but now I've become used to the deletion process, and make it a monthly housekeeping task. OP, if it's enabled on the phones then I would do a complete restore of both...There is no reason they wouldn't show up.
     
  7. mattopotamus macrumors G4

    mattopotamus

    Joined:
    Jun 12, 2012
    #7
    I kind of agree. Sometimes I hate having photostream on my phone b.c it is like 2 of the same albums, but the idea is so that when you delete it in one place it is gone in them all.
     
  8. memphisbeatles thread starter macrumors newbie

    Joined:
    Oct 19, 2012
    Location:
    Memphis, TN
    #8
    Ha...this is an interesting point. I can see the blessing comment ... but you don't really have to delete the PhotoStream ever...it just replaces old photos when you reach 1,000 with new ones, if that is what you mean. I've got 986 on my iPad and obviously same on iPhoto/iMac, but Zero on iPhones, lol. Same PhotoStream, same ID, and photos I take from phones ARE showing up in STream on OTHER Devices.

    Have the PhotoSTream on the two iPhones is relatively redundant because they are already in the camera roll, but i would LOVE to see photos my wife takes from her iPhone on MY iPhone. If I have to set up a shared PhotoStream I will ... but I like everything being on one iCloud log in, Apple ID, etc. Is just so weird, that the photos I take ON MY IPHONE, show up in the PhotoStream server (including my Iphoto and my iPad, and I'm sure will show up in Apple TV), but not on the Phone's PhotoStream itself. Completely blank. WIERD with a capital W!
     
  9. memphisbeatles thread starter macrumors newbie

    Joined:
    Oct 19, 2012
    Location:
    Memphis, TN
    #9
    Well, I completely removed my iCloud account from phone. And, now, it is working after re-adding. Really REALLY WEIRD. Phew. Sigh.

    This is my first post on Mac Rumors so look forward to talking with you all and joining the community.

     
  10. vastoholic macrumors 68000

    vastoholic

    Joined:
    Jan 28, 2009
    Location:
    Tulsa, OK
    #10
    Glad you fixed it. And welcome! Didn't realize you were new.
     

Share This Page