Pismo boots on OS 9 but not on OS X

Discussion in 'MacBook Pro' started by n2zcars, Apr 4, 2009.

  1. n2zcars macrumors newbie

    Joined:
    Apr 4, 2009
    #1
    I have 3 Pismo's and have an issue with one that was stored as a parts machine for years. I recently replaced the upper half(screen) and it started up just fine. booted into OS X 10.4 with no problem upon the next restart it showed the gray apple and then showed a large box (larger than heat shield) then shut off. Upon restart it would do the same sometimes it seems to have booted up to os X but upon another restart it would fail. Upon several tries it would sometime just freeze and others open the box and shut off.
    I took the same hard drive and cloned it to another drive. This drive and the OE drive will boot up my other Pismos but not this one. I installed another HD that only had 9.1 on it. It boots fine and works fine. It does a complete reset when it shuts off as when it does boot it needs date and time reset.

    I went to Apple and installed the firmware update. It didn't install as Apple said it would but upon trying to reinstall it later it said it was already updated. It worked fine for a few starts and after doing some updates on the other Pismo the one in question is back to not starting in OSX but fine on OS 9.

    Is there some chance that the firmware isn't really installed?
    I am going to try to reinstall firmware but in the meantime if anyone has ideas...

    Jeff (crosseyed and grumpy)
     
  2. n2zcars thread starter macrumors newbie

    Joined:
    Apr 4, 2009
    #2
    adl information

    I have tested and retested this but it is like most of the time it will boot up once into OS X but then will go to shuting it's self off and resetting date.

    I have started up with option key and have had some luck but it's nat always a sure cure.

    If I learn anything new I'll post but once again I can fire up this HD in any mac and it runs, any other HD w/ OX10.4 has the same problems and only on this puter.

    Ideas???

    Jeff <-- still cross eyed and grumpy Kinda like "Walter"
     
  3. n2zcars thread starter macrumors newbie

    Joined:
    Apr 4, 2009
    #3
    update Please I am losing hair!!!!!!!!!!!!

    The PB has the same problem even after confirming the firmware update was installed. It had the exact same problem.
    I tried to boot from another HD on another Pismo and it was erratic and acted the same as the internal drive. Booted off of a back up drive via Firewire and it did the exact same set of actions with that one too. The drives boot fine on both my other machines.
    Every few starts it never gets to the spinning wheel. It just locks up or resets with a rectangular black box is the last thing you see.

    4 hard drives and they all knock this machine to it's knees but all 4 work fine on 2 other machines? I swapped processors and RAM, HD's, and it still acts the same. Is this a logic board or sound board It still refuses to consistently boot OS 10.4 but boots to 9.0 and 9.2, never fails

    I am erasing one HD and reinstalling known good operating system and trying it once again.
     
  4. risenphoenixkai macrumors member

    Joined:
    Oct 14, 2008
    #4
    It sounds like the PRAM battery might be dead, especially since you mentioned the date resetting all by itself. But there's a couple other things you can try first and see if it works.

    First, do a PMU reset. I think the Pismo does this by holding Shift-Fn-Ctrl-Option on the left side of the keyboard and then hitting the power button.

    If that doesn't work, there's a program called XPostFacto that I used to use on an old Wallstreet Powerbook to get it to boot into 10.4, even though the max OS that model supported was 10.2.8. Even though the Pismo natively supports 10.4, it's possible that XPostFacto might kick it in the pants enough to get it to boot. You can google for it to find where to download it. Download and install it, then run it from OS 9; the computer will reboot, and hopefully boot into OS X.

    If that doesn't work, then you might have a hardware issue with the Pismo, especially if the same HD is working fine in other machines. Like I said before, it's most likely the PRAM battery, which is a major pain to replace.
     
  5. MacTech68, Apr 15, 2009
    Last edited: Jan 30, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #5
    The rectangular black box sounds like a kernel panic but it's never able to draw text in the box.

    I've seen a few Pismos with fried processor cards that have similar problems or refuse to boot at all.

    Since you say you've swapped OSs, HD and CPU, have you tried swapping RAM? Take it back to a basic 256MB (with a single SO-DIMM if you can).

    Also, try removing everything you can. External Monitors, PC cards, user removable battery, the DVD Drive, Internal HD and all peripherals including USB devices (except for a known good FireWire HD with 10.4 on it).

    Try powering on with CMD-OPTION-O-F held down. When you see text on the screen, type each of these followed by a the return key after each line:

    reset-nvram
    set-defaults
    reset-all

    After the last line, the machine should type some short text on the screen, blank the screen and then restart.

    Also, try leaving the machine (with all the above devices removed) connected to the AC Adapter for 48hrs - (see note below).

    Another thing to try would be to remove the internal backup battery for 24hrs. You must leave the AC Adapter disconnected. The battery is very easy to disconnect in the Pismo. Simply pull straight up on the red/black/white cables seen in the bottom right of this photo where they connect to the circuit board. You'll need to remove the DVD Drive to see it. You don't need to remove the battery from it's black pocket at all, we just want to clear the pram completely.

    I've seen many older PowerBooks that have been left in cupboards for many months that won't boot at all or properly until the PRAM battery is removed overnight. What happens is that as the battery depletes, it corrupts the PRAM. Using the normal methods of clearing PRAM don't work! You must remove the battery. Note that internal batteries in most of the older PowerBooks are rechargeable Lithium and need about 48Hrs on the AC Adapter to fully charge when depleted.

    That should keep you busy. :( Good Luck!
    ________
    Ferrari 340
     

Share This Page