Please explain battery usage because mine is blank

Pinkstiletto66

macrumors 6502a
Original poster
Dec 12, 2010
501
1
New York City.
I disabled plenty of unneeded things to save on battery. Went into general then to usage and its blank and says it will show battery usage once it's charged.

Isn't the usage it shows after its charged the usage after its charged?

I want to know the current usage. It didn't show me at 40 percent left.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,516
8,770
Ventura County
I disabled plenty of unneeded things to save on battery. Went into general then to usage and its blank and says it will show battery usage once it's charged.

Isn't the usage it shows after its charged the usage after its charged?

I want to know the current usage. It didn't show me at 40 percent left.
Current usage is what you have used since last full charge, not what you have remaining left on the battery. Once you charge it back to 100% the ticker will start showing the usage and standby time since that last full charge.
 

Pinkstiletto66

macrumors 6502a
Original poster
Dec 12, 2010
501
1
New York City.
I think something is wrong because I still have no usage shown after a full charge. It use to show it, now it's not. I like knowing because I felt my battery was going so after removing some stuff and calibrating the battery I wanted to know if it was helping.
 

Waughy

macrumors regular
Jun 20, 2012
221
53
Australia
Looks like you are jailbroken, this seems to be the cause of battery stats not showing. I've noticed that on all my phones when I have jailbroken.
 

Pinkstiletto66

macrumors 6502a
Original poster
Dec 12, 2010
501
1
New York City.
I was just about to update. I read that if you respring that happens. Thing is I've been jail broken for about a week. Did a respring quite a few times and its only happened recently. I read that it's suppose to fix itself after charging to full battery but hasn't since. I will recharge again (at 89 percent) and see what happens.
 

Pinkstiletto66

macrumors 6502a
Original poster
Dec 12, 2010
501
1
New York City.
I did a respring earlier in the day when I posted at about 20 %. Then it got to lower so I plugged it in and turned it off to charge to 100%

I thought once I went to 100% that would then make it return to normal but didn't. Well I'm at 91% I will charge it full again and if that doesn't work then I will let it go to 0% (most likely by tomorrow or in the early morning. Will keep you posted.
 

Waughy

macrumors regular
Jun 20, 2012
221
53
Australia
I'll check mine after the next charge, it's been resprung once today so stats are blank. I thought it was a jailbreak thing that you lost your stats altogether. Now I know different.