PLEASE GIVE ME a piece of mind (MacBook Pro Screen Shaken)

Discussion in 'MacBook Pro' started by Derrick Velasco, Feb 7, 2009.

  1. Derrick Velasco macrumors regular

    Joined:
    Aug 17, 2008
    #1
    My mentally ill brother grabbed our $2700 17inch older gen MacBook Pro and shook it back and forth as hard as he could, I was able to stop him and he will not be using it again.

    Is it okay? It seems perfectly fine. But maybe something internal?

    PLEASE TELL IT WILL BE OKAY!

    We got this MacBook Pro from the Apple Store right before the new one came out.

    The only 17 inch that was on the store...
     
  2. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #2
    you should see the testing these products go through during r&d
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    Should be fine, the only problem would be the HDD, but the sudden motion sensor should have shut that off.
     
  4. Derrick Velasco thread starter macrumors regular

    Joined:
    Aug 17, 2008
    #4
    WOW! Thanks for the prompt reply! He shook the LCD not the computer itself.
     
  5. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #5
    Then you might see some premature wearing of the monitor cable, but Apple should replace that if you have AppleCare.
     
  6. Derrick Velasco thread starter macrumors regular

    Joined:
    Aug 17, 2008
    #6
    Thank you...
    ugh I wish I could have prevented it, Such a beautiful computer, It looks completely normal.

    Nothing bad so far. But thanks for being honest..
     
  7. sehnsucht77 macrumors 6502

    Joined:
    Dec 26, 2008
    #7
    next time, keep him away from your stuff. you'd worry less about losing your work or wrecking your computer.
     
  8. Abstract macrumors Penryn

    Abstract

    Joined:
    Dec 27, 2002
    Location:
    Location Location Location
    #8
    Wirelessly posted (Nokia 5800 Tube XpressMusic : Mozilla/5.0 (SymbianOS/9.4; U; Series60/5.0 Nokia5800d-1/10.0.010; Profile/MIDP-2.1 Configuration/CLDC-1.1 ) AppleWebKit/413 (KHTML, like Gecko) Safari/413)

    If there's nothing wrong, then there's nothing wrong. ;)
     

Share This Page