Please Help!! (Safari can’t open the page)

Discussion in 'Mac Basics and Help' started by User X, Mar 4, 2006.

  1. User X macrumors member

    Jul 17, 2002
    I am running 10.4.4 on a powermac g4 and have a problem running software update as well as veiwing certian websites including When trying to load the Apple site, it tells me "Safari can’t open the page “” because it could not connect to the server “”.

    The same thing happens when tying to run software update it tells me it cannot connect to the server.

    My internet connection is fine, I can surf most other sites with no problem and can be be loaded from my windows laptop as well as an old imac. All computers are connected wirelessly to a netgear hub. I tried clearing the cache and reseting Safari. I also ran OnyX and ran all maint scripts as well as verifying permisions. So far no luck. This has been a problem for about three weeks now. Does anybody have any ideas??
  2. discoforce macrumors 6502a


    Jan 27, 2004
    Vermont, USA
    You've tried everything I could think of, except for connecting your computer to the modem via ethernet (though that would be kind of desperate).

    Maybe time to call Apple?
  3. climhazzard85 macrumors member


    Dec 28, 2005
    Have you tried using a browser other than Safari to see if the problem still exists? This sounds more like a isp/router issue than software, but who knows. Try firefox and see if it still exists..if so, it's not safari.
  4. PlaceofDis macrumors Core

    Jan 6, 2004
    i agree with trying another browser so you can isolate the problem. if it loads fine in Camino or Firefox, well then its a Safari issue. if not its a hardware problem. if it doesn't load in another broswer, try connecting to the internet via ethernet and see if that works.
  5. User X thread starter macrumors member

    Jul 17, 2002
    OK, I downloaded Firefox and I still have the same problem. WTF?? I will have to find a long ethernet cable to try a direct connection.
  6. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    You haven't installed PeerGuardian have you? I know it blocks some of the addresses
  7. User X thread starter macrumors member

    Jul 17, 2002
    Nice Catch!

    PeerGuardian was it!! I threw it in the trash and restarted. I am running software update as I type. Thank you everybody for your reply's especially Applespider. This one was driving me crazy.

Share This Page