Please help - ZiPhone Mac GUI has given me an unlocked phone that can't make calls!

Discussion in 'Jailbreaks and iOS Hacks' started by superdude22, Feb 13, 2008.

  1. superdude22 macrumors newbie

    Joined:
    Feb 13, 2008
    #1
    I had a 1.1.2 jailbroken phone on AT&T that worked perfectly.

    I upgraded to 1.1.3 through iTunes and then used the Mac GUI version of Ziphone that was just released (see a few threads down) and my iPhone now fails on all calls. When I start the phone, it "Searches.." for service for about three seconds, then appears to show only one bar, without the AT&T sign.

    I've tried jailbreaking and activating multiple times, and have reset a bunch of times too. I've even tried restoring to 1.1.3, and I still get the same problem, which makes me think it has something to do with the baseband (?).

    I've tried SSH'ing into the phone and replacing lockdownd with a patched version, which seems to have done nothing...

    I have not yet tried the "Unlock", as I have been avoiding these (I want my warranty to stay intact).

    Please help!
     
  2. hobo macrumors regular

    Joined:
    Mar 13, 2005
    #2
    I was told in another thread that you may need to do Unlock to get any AT&T SIM to work that's not on the iPhone plan...

    I tried it, but I have bootloader 3.9, not 4.6, so I got stuck with the Incorrect SIM error... and the revirginizing runaround
     
  3. Aries326 macrumors 6502

    Joined:
    Dec 28, 2007
    #3
    Just for testing purposes, I used ziphone 2.0 even though my iphone was already jailbroken and unlocked with the command line version. For some reason, the command line version works and the GUI version just gives me problems.

    Everything worked with my jailbroken phone. When I unlocked it, the only thing that didn't work was the map locator.
     

Share This Page