Plex and 4K “Network too slow” on Ethernet?

mcdj

macrumors G3
Original poster
Jul 10, 2007
8,894
3,987
NYC
I have a Synology NAS with gigabit Ethernet for storage, connected via Ethernet to a Synology 2600 router. Also connected to the router via Ethernet are a 2014 Mac Mini 2.6ghz, 16gb ram, which runs the Plex server, and an Apple TV 4K.

No problems playing 4K content from sources like ITunes rentals or YouTube on ATV.

But the Apple TV Plex app is choking on 50gb+ 4K files stored on the NAS. Star Wars 4K77 is non stop jitter. Other files play for a while, a bit jumpy, then freeze a bit, then play some more, then freeze, etc.

I often get a message saying my network connection isn’t fast enough.

All Plex conversion settings are set to original/maximum. If I turn on automatic conversion, I get a message saying my processor isn’t fast enough.

Do I need a more powerful Mac mini? There’s no WiFi involved so I don’t know how much faster I can get network wise.

thanks.
 

ActionableMango

macrumors G3
Sep 21, 2010
9,511
6,701
Assuming your gigabit Ethernet network is working properly, bandwidth is not the problem.

The legitimate streaming sources all work because they are streaming content to the ATV in a format that is supported by ATV's hardware acceleration. It's not about bandwidth--heck, they are streaming over the Internet to your home, which is for most people way, WAY slower than gigabit Ethernet.

Almost certainly your pirated content is in a format that is not supported by ATV's built-in hardware acceleration. If you set Plex to original, your ATV is receiving the unsupported video format, and so ATV struggles to play it back without the benefit of hardware acceleration. If you set Plex to transcode on the fly, it will send a fully supported video format to the ATV. The problems with that are (A) your Mac Mini has insufficient CPU power to keep up with transcoding on the fly, (B) transcoding on-the-fly results in loss of picture quality (and often audio quality too)--it is optimized for speed instead of quality.

IIRC, Plex can transcode ahead of time, making a copy that is compatible with your ATV. Your Mac Mini is capable of this because it doesn't have to keep up with real time playback--it will just take however long it takes. Doing this should work, but the drawback is that much more disk space will be used because you have two copies of every title, and you're not getting the full quality of the original file when you are playing back the transcoded file.

The other possibility I can think of only applies if you have one of the cheaper, lower-end Synology NAS units. Those have just barely enough CPU and memory to get out of their own way. In my experience if you do anything challenging at all, like turn on file encryption or having hundreds to thousands of files in a folder, they choke and have very poor file serving performance.
 

CoastalOR

macrumors 68030
Jan 19, 2015
2,585
944
Oregon, USA
I think there has been a bug with the Plex Media Server (PMS) app since around version 15. I have been having the same server too slow from Plex sometimes from my Mini to the aTV. I went to the Plex forums and saw some discussions about problems.
 

Tesla1856

macrumors member
Jul 25, 2017
69
22
Texas, USA
Check the NAS transfer rate of a large file to Mac (outside of Plex). My Synology DS412-Plus likes to slow-down from 100 to around 20. I run CAT-5e/CAT-6 and have a nice gigabit-1000 managed switch (gigabit backbone).

IIRC, seems to have started a year-or-so ago when I upgraded to DSM-6.x . I'm fully loaded with 4tb x 4 =16tb Synology-Hybrid-RAID (RAID-5 with 1-disk fault tolerance) . It's sad, but works fine other than that.
 

Dameatball

macrumors regular
Feb 7, 2014
114
47
San Francisco
It’s most likely the client can’t handle a file/bitrate that large is my guess, or if it requires transcoding to play then the mini/server may be the issue. What happens when you play it on a browser?

FYI a lot streaming devices are going to choke on something that substantial. Again try some other clients and see what the result is.