Apps Pluto TV Not Working

mg6035

macrumors newbie
Original poster
Nov 1, 2015
26
6
Pluto TV has not been working for me for a while now. Apple TV4K. When I try to open the app it does nothing. It just goes back to the Apple home screen. I have the latest version and also the latest TVOS. Anybody else having this problem? Any ideas?
 

Zimmy68

macrumors 68000
Jul 23, 2008
1,813
1,142
Wow, I knew it wasn’t working on beta, but now you are saying it is not working on tvos11?
You have me worried.
 

mg6035

macrumors newbie
Original poster
Nov 1, 2015
26
6
Wow, I knew it wasn’t working on beta, but now you are saying it is not working on tvos11?
You have me worried.
It wasn’t working for me on TVOS11. I updated to TVOS12 gold master Friday and it’s still not working. We’ll see if it works tomorrow when 12 is officially released. But the gold master is usually the same as the official release so I’m not hopeful.
 

Zimmy68

macrumors 68000
Jul 23, 2008
1,813
1,142
Hopefully it is just an issue with Pluto and they need to update their app.
I love Pluto and hope it is just an app issue.
 

mg6035

macrumors newbie
Original poster
Nov 1, 2015
26
6
Hopefully it is just an issue with Pluto and they need to update their app.
I love Pluto and hope it is just an app issue.
I had emailed them and I just heard back. They think it is a problem with the TVOS 12 beta and they are working on an update to correct the problem. They say the next update will have Pluto working again. No mention of a date but obviously it’s a priority.

Fingers crossed.
 

Heat_Fan89

macrumors 6502a
Feb 23, 2016
623
518
Pluto TV has been working great under tvOS 11, never had a problem until I updated yesterday to tvOS 12. Now it just crashes as soon as I open the app. I'm glad they are looking to fix it. It's one of my favorite apps.
 

mg6035

macrumors newbie
Original poster
Nov 1, 2015
26
6
Pluto has updated! Works now on TVOS 12. Good response by them.
 

sqig

macrumors newbie
May 7, 2014
4
0
PlutoTv Has been working well on my AppleTV 4k until the app updated yesterday.
Now I can use the in demand service but only see a black screen and sometimes a loading bar at the bottom when trying to see Live channels.
I have tired deleting the app and reloading it but with the same results.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.