PMG5 Won't read any discs in brand new DVD drive

Discussion in 'Mac Basics and Help' started by brianus, Jan 9, 2006.

  1. brianus macrumors 6502

    Jun 17, 2005
    Ok, so I installed a brand new Pioneer DVR-610 (or 110D, whichever you prefer) in my boss's Dual 1.8GHz PowerMac G5 to replace the original writer, which worked but had a lot of trouble reading DVD-R discs. The 610/110D, however -- which was recommended by people on this forum and by companies like OWC for my model of Mac -- won't read *anything*. It shows up in System Profiler, the tray can be open and closed with the keyboard eject key, and I can hear it spinning up when a disc is inserted. But nothing happens. Nothing's mounted on the desktop or in the Finder sidebar; nothing shows up in Disc Utility; and after a minute or two, assuming I leave it in, the tray pops back out, having failed to mount the disc. Hoping a firmware upgrade would solve these problems I used the "DVRFlash 2.2" utility and successfully upgraded from firmware 1.17 to 1.37, but the drive continues to exhibit the same symptoms.

    I have tested commercial audio CDs, CD-Rs, DVD-Rs, and a CD-RW (all Mac-formatted and verified to work in other G5s in the office). Same results for everything.

    Apple's FAQ about this sort of thing is of no use; it doesn't appear to have been updated since the OS 9 days, so there's all this stuff about "Extensions" that as far as I can tell don't even apply to OS X. We don't use Classic in the office, and besides, once I figured out which of the 8 bazillion "Extensions" folders they were talking about, I didn't see any difference between the one on my boss's computer and the other G5s.
  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    Jumpers are set correctly? Tried drive in another machine to eliminate drive as the problem?

Share This Page