poor quality of Desktop images when taken from iPhoto/Aperture

Discussion in 'macOS' started by apple_iBoy, Dec 27, 2007.

  1. apple_iBoy macrumors 6502a

    Joined:
    Oct 28, 2003
    Location:
    Philadelphia, PA
    #1
    I've noticed that when I set a picture from Aperture or iPhoto as my desktop image, the quality is often exceptionally bad. The pictures look pixelated or full or artifacts. I am selecting the pictures by going to the System Preferences Desk settings and choosing them from the iPhoto or Aperture lists.

    I would expect this if the images were too small and Leopard was expanding them to fill the screen (1680x1050) but some of these pictures are 10.2 megapixel behemoths. They look beautiful when viewed in full screen in Aperture. I've tried looking at some images centered on screen at native size, no stretching, and they still look like garbage, with all sorts of color banding and such.

    What gives? Just a bug that will be fixed later, hopefully?
     
  2. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #2
    While not a "scientific" method. I exported a photo at full res out of iPhoto to the desktop. Then in iPhoto I set is as desktop picture. Next I opened the preferences and changed it to the exported one, I noticed no shift or anything. Could not even tell the swap was made.

    What is the original format? Mine are both JPEG, original and exported.
     
  3. taylorwilsdon macrumors 68000

    taylorwilsdon

    Joined:
    Nov 16, 2006
    Location:
    Bay Area
    #3
    You may be assigning the thumbnail file from Aperture or iPhoto to be your background instead of the original. Try exporting them at full resolution, putting it in the pictures folder and opening it through the "Change Desktop Background" dialog.
     
  4. apple_iBoy thread starter macrumors 6502a

    Joined:
    Oct 28, 2003
    Location:
    Philadelphia, PA
    #4
    That's the ticket. Exporting the files into another folder fixed it right up. Choosing from the Aperture folder in the Desktop preferences or dragging a file from Aperture to a folder both look lousy.

    Any way I can choose pictures without the export method and still have them come out looking okay? Seems kind of messy to have the option to directly select pics there in the Desktop preference pane if it's not going to work properly. I've set the preview quality setting in Aperture to high.

    EDIT: I'm updating all my previews in Aperture right now to have them all with the higher quality settings. Looks like it's going to take awhile, but hopefully this will help.
     

Share This Page