Possible fix for spotlight not showing any results (even after a rebuild)

Discussion in 'macOS' started by Soulstorm, Jan 15, 2011.

  1. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #1
    Well, I just thought it would be nice to share this among the forum, just in case it helps someone.

    I have a Core 2 Duo macbook pro, with Snow Leopard inside, and my disk shared between windows 7 and OS X.

    Lately, I had noticed a very strange behavior. Spotlight did not show any results! The spinning sign to the left of the blue search bar appeared to be running, but no results whatsoever,

    I did a rebuild on the spotlight index. The process took about 4 hours, and it worked just fine after the rebuild. Until I restarted the computer, where the problem reappeared. In Activity Monitor, the 'mds' utility took about 10 mbytes of RAM, and my hard drive was working with transfer rate about 3 mbytes /sec (whith no process running with above 0.3% CPU usage).

    Which got me thinking that this may be a HDD issue, where spotlight is searching my HDD for something, but due to some problem, it couldn't find it, and it could continue until it does.

    I then included my Boot Camp partition to the list of folders that shouldn't be searched by Spotlight. Voila! It worked. The Boot Camp partition was NTFS, and I had NTFS-3G installed to read and write to the disk. But it seems that NTFS isn't spotlight friendly anymore, so I excluded the disk from spotlight searching and everything works fine.

    Still doesn't know why the problem appeared after a year of including my Boot Camp partition to the searches, though.
     
  2. vertigo78 macrumors regular

    Joined:
    Oct 2, 2008
    #2
    thanks, been trying to fix this. i had the same things you did.
     

Share This Page