Possible Solution for Ultrasnow 1 bar vs No MMS/Visual Voicemail dilemma??

Discussion in 'Jailbreaks and iOS Hacks' started by kmichalec, Jul 8, 2011.

  1. kmichalec, Jul 8, 2011
    Last edited: Jul 8, 2011

    kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #1
    Ok. I just rejailbroke my previously jailbroken iPhone 4, upgrading from firmware 4.2.1 running Baseband 1.59.00, to 4.3.3 still running 1.59.00. Used Snowbreeze to jailbreak it, and everything went smoothly. However, noticed that once I was done, my signal showed only 1 bar no matter what (even though it appears to really have a much stronger signal). After looking around onlline, realized this was a known issue, and the recommendation was to install Ultrasnow 1.2.3, even though I'm running with AT&T and really don't need to have Ultrasnow installed, as I'm not unlocking at the moment. However, upon installing Ultrasnow 1.2.3, it fixed the 1 bar issue, however, introduced a new issue with not being able to send/receive MMS and not able to receive new Visual Voicemail.

    I was perplexed, as after further research, there seemed to be no known fix. It was either I had to choose to live with the cosmetic issue of only seeing 1 bar when I really had more or less than 1 bar, or I chose to live with seeing my bars correct, but losing MMS and VV.

    After trying a number of things, I THINK I may have found an answer (so far, so good). What I wound up doing was installing Ultrasnow so the signal issue would fix. Then, I installed the Ultrasnow SBSettings Toggle. After the Signal indicator was working correctly, I toggled off Ultrasnow (leave it installed, but just turn it off). After doing that, my signal indicator continues to work as expected (true indication of signal strength), as well as MMS and VV started working too.

    Haven't tried rebooting the phone yet, so we'll see what happens when that time comes. But for now, I'm on 4.3.3, with Baseband 1.59.00, with Ultrasnow 1.2.3 installed, but turned off, and I have a true signal indicator, and have MMS and VV working.

    I'll keep everyone posted as to how things progress...

    Thanks!

    kmichalec:D
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Wow, very nice find there bro.
    Let us know how it goes and if it lasts after restarts etc....
    I have ultrasnow installed also for the exact same reason and Im on AT&T.
    At time I will lose my visual voicemail and MMS function. Not even after reboots or anything. It will just stop working at random times. People leave voicemails that I never get etc...
    Untill I reboot and pop out and back in the sim tray but it is a pain.
    Your solution sounds better if it ends up working and functions like it should be in the long run.
     
  3. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #3
    I've resisted installing ultrasnow due to the known issues with messaging; hopefully this will work at least between reboots. My baseband isn't unlockable at present but I haven't given up hope yet!
     
  4. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #4
    DEFINITELY let us know what happens with reboots. I've been resisting moving up to 4.3.3 with 1.59 because of this issue (still on 4.2.1). My phone has a case that makes popping the SIM in and out more than occasionally a real pain. I'd love a solution that allowed me to upgrade!
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    As soon as you respring, Ultrasn0w (even with toggle to off) kills MMS and VVM on my iPhone4
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    That sucks:(
     
  7. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #7
    Although I haven't tried it personally, I would try a Gevey Ultra before ever installing Ultrasn0w, given the software is buggy.
     
  8. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #8
    Given that ultrasnow is free and legal, I think it's a much better option even with a few bugs.
     
  9. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    UPDATE:

    As someone else aluded to here, it seems to survive a respring, but not a reboot. However, if you don't mind the extra couple steps, if you know your going to reboot, you can turn Ultrasnow back on via SBSettings before you reboot, then after you have finished the reboot, turn it back off again is SBSettings. Seems to work that way for me. Only thing I have noticed is my battery seems to drain a little quicker when Ultra is installed (regardless if on/off), but it's not terrible. Small price to pay.

    Hopefully, the maker of Ultra figures out what's causing the 1 bar vs MMS/VV issue, and can correct it soon.

    Hope this helps everyone!
     
  10. terraphantm macrumors 68040

    Joined:
    Jun 27, 2009
    Location:
    Pennsylvania
    #10
    I don't want to badmouth the dev team, but... The no VVM/MMS issue has been there since the initial ultrasn0w release, but they haven't acknowledged it to date. Wasn't a big deal before 4.3 since official carrier users didnt need ultrasn0w. The only fix that I've found works reliably is ejecting and reinserting the sim. I tried the toggle a while ago and it never seemed to help.

    I do wish they'd make an application that fixes the 1 bar issue without attempting an unlock. I wonder if it's possible to spoof a different BB version just so ultrasn0w doesn't bother trying to unlock.
     
  11. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    I agree completely. Just an app that fixes the signal bar issue would be perfect. I don't need the Ultrasnow unlock at the moment as I'm on AT&T, but I'm maintaining my baseband for future "just in case".
     
  12. nsfw macrumors regular

    Joined:
    Aug 21, 2009
    #12
    Anyone try jamming jailbreakme onto of their dev team jailbreak? Wondered if that could help this issue. But pretty low chance.
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    That has nothing to do with the signal bar issue.
    And its pointless to try to JB the same phone twice with 2 different programs.
     

Share This Page