Powerbook 12" Battery keeps charging (but it isnt)

Discussion in 'Macintosh Computers' started by blackbird, Dec 12, 2003.

  1. blackbird macrumors newbie

    Sep 20, 2002
    New Jersey
    I have a powerbook 12" running Panther. For some reason my battery keeps charging... but it isn't. The battery monitor says its at 84% and charged. When I click on it, it keeps saying calculating until full... Well my light has been amber for about 3 days now.

    I tried draining the battery all the way down thinking that was the problem... it didn't help. Then, I have tried taking the battery out and putting it back in and still no luck. Now I am not sure what to do really.

    Any questions, comments or suggestions would really help.

    Thanks & Happy Holidays,
  2. MoparShaha macrumors 68000


    May 15, 2003
    San Francisco
    I was having some similar funky problems with the battery on my 12" as well. I restarted the computer, and that took care of it. If you haven't restarted, give it a shot. If that doesn't work, reset the power manager. I forget exactly how to do this, do a search of Apple's support section, it will tell you how. That usually clears charging problems.
  3. blackbird thread starter macrumors newbie

    Sep 20, 2002
    New Jersey
    Thanks for the reply. I did restart multiple times and still the same thing. I will do some research on this "power manager" and maybe it will be easier to fix my problem for the next time it happens, but I have fixed the problem and have not figured out why it did what it did.

    Here is what I did just incase anyone else is having the same problem:

    While the powerbook was plugged in and running. This is sort of hard to do so work on a soft surface for when the battery falls out.

    ** Laptop should be on while doing this, putting it to sleep does not work I tried **

    1) I dropped the battery out so the system seen no battery.

    2) I put the battery back in while the laptop was on.

    3) I unplugged the power so it drained to about 80%.

    4) I plugged it back in to charge.

    5) I left the lid open so it was charging but not sleeping.

    6) Soon enough (30 - 45 min), the battery i guess seen it's problem and went to 100% and now my light is no longer amber! Funny thing was it said 2hrs 45 min left to charge from 80% but it didn't take that long.

    I hope this helps anyone with a similar problem and thanks MoparShaha for the post about the "power manager" this might be an easier thing to do for the next time this happens.

    Thanks again,
  4. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    I just bought a 12" G4/867 PB (irresistible price from Amazon!), and it had the same charging problem right out of the box. It never got above 78% and the light remained amber. A search of the AppleCare database turned up nothing of use until I searched for "reset power manager."

    That did the trick. For the 12" G4 PB, this is how it's done:

    1. If the computer is on, turn it off.
    2. Reset the power manager by simultaneously pressing and then releasing Shift-Control-Option-power on the keyboard. Do not press the fn (Function) key while using this combination of keystrokes.
    3. Wait 5 seconds.
    4. Press the power button to restart the computer.

    Worked for me. The PB now charges to 100%.

Share This Page