Powerbook G4 Forced Sleep

Discussion in 'Macintosh Computers' started by ezsober, Mar 29, 2004.

  1. ezsober macrumors member

    Aug 14, 2003
    I've had my powerbook G4 (867 mhz) for about eight months. While it ran flawlessly for the first six months, during the past two, its been causing me headache after headache.

    Recently, applications began crashing indiscriminately, right after bootup. That problem has been temporarily solved, but a new problem emerged to take its place.

    The computer periodically, without warning, even with the battery at 100% and the AC plugged in, will force itself to sleep. Nothing will rouse the computer from its slumber. I even tried taking out the battery and unplugging the computer. This does nothing. Although if i take the battery out and leave the computer alone for five minutes, and then put the battery back in, with the electricity replugged, it'll wake itself up, albeit with the battery at 0% charge.

    Has this happened to anyone? Is this normal? Am i missing something?

    I've become more dissapointed with Apple's powerbooks of late. There is no reason why i should drop 1000+ dollars on a computer that starts to malfunction after 6 months. This thing should last for several years...
  2. Celeron macrumors 6502a

    Mar 11, 2004
    It seems weird that the battery shows 0% charge after you are able to get the machine to boot backup. I know you mentioned this also happens while the machine is plugged into AC, but does it happen without the battery at all? Try running on just AC power with no battery installed.

    Try running this command in a terminal and see what you get:
    ioreg -l | grep -i IOBatteryInfo

    It should spit out a line that looks similar to this:
    "IOBatteryInfo" = ({"Capacity"=4186,"Amperage"=1256,"Current"=2416,"Voltage"=11310

    This is battery info, so it will be interesting to see what it says on yours. This reading was from my new 12'' Powerbook 1ghz.
  3. titaniumducky macrumors 6502a


    Nov 22, 2003
    I can almost GUARANTEE this is a problem with your PMU (Power Management Unit). Reset the PMU to fix this. Apple's site has info on how to do this: http://docs.info.apple.com/article.html?artnum=14449#faq9

    Check that article for your PowerBook version's instructions. If your not comfortable (doesn't usually involve more than removing the keyboard) let Apple do it - you're still under your one year warranty.

Share This Page