Powerbook G4 Optical Drive Stuck?!

Discussion in 'Mac Help/Tips' started by elliotay, Jul 3, 2003.

  1. elliotay macrumors regular

    Jul 9, 2001
    So just a few seconds ago I was trying to install some new software on my Powerbook G4 800 mhz. I put in the cd and the optical drive starts making noises like it's trying to recognize the cd. But it never does. The thing never mounts and pushing eject won't eject it. I have to restart to get the cd out. I've tried it with several different cd's and it's the same result. I was just watching dvds on it last week. What happened?
  2. iGav macrumors G3

    Mar 9, 2002
    Re: Powerbook G4 Optical Drive Stuck?!

    I had this happen on my Rev A and my SuperDrive on my latest PowerBook G4 get yourself a very good (expensive) DVD cleaner disc, and give that a whirl... probably won't fix it, but it's worth a try...

    Failing that, send it to Apple, as they replaced mine in the end.

    Good luck...
  3. iJon macrumors 604


    Feb 7, 2002
    repair your permissions just to make sure although it may no help, then i would zap your pram. also, can you boot of a cd. if you can boot off of a cd then you know your drive isnt bad.


Share This Page