Powerbook wont eject CD!

Discussion in 'Macintosh Computers' started by PBGPowerbook, Jun 17, 2004.

  1. PBGPowerbook macrumors regular

    Jan 6, 2004
    PB 12 867 10.3.4

    When I drag the CD to the trash or command-E, it spins, stops, pauses, and re-appears on the desktop. I tried restarting but no luck.. what should be done?

    btw it's The Best of the Velvet Underground, if that's any help.
  2. themadchemist macrumors 68030


    Jan 31, 2003
    Chi Town
    I don't know if this works, but it sounds promising:
    Ejection Seat

    Also, I see a hole in the top left corner of my PB. I tried to stick a paperclip in it, but nothing happened. I thought it might be some fashion of emergency eject hole, but it's clearly not. I hope I didn't do any damage. Anyway, it doesn't make sense that it would be, because it's so far removed from the drive.

    Good luck!

    edit: oh crap, that was the microphone...no wonder I heard a little 'snap.' That's no good...dammit! I'm such a dumass. Remind me never to try to help anyone with anything. Oh well, off to the Apple Store to get this fixed.

    edit again: ok, well, the microphone still seems to be working. Still, somebody laugh at me for my idiocy.
  3. PlaceofDis macrumors Core

    Jan 6, 2004
    if the "Ejection Seat" program doesn't work, i would try rebooting again and as the book is still loading OS X hold down the 'eject' key and the disc should pop out then, this at least works for me, and worth a try

    finally if nothing works i guess you will have to send the book into apple or go visit an apple store for help

    good luck
  4. russed macrumors 68000


    Jan 16, 2004
    i've heard that the eject button in itunes works in cases when other methods dont work. i dont know why but i have read that in several places
  5. crees! macrumors 68000


    Jun 14, 2003
  6. PBGPowerbook thread starter macrumors regular

    Jan 6, 2004
    eject button does not work in finder, itunes, or disk utility. startup with mouse down does nothing...anyone?
  7. robbieduncan Moderator emeritus


    Jul 24, 2002
    Try rebooting into Open Firmware (Command-Option-OF at boot) and typing "eject cd" (without the quotes" at the command prompt. To get back to OSX type macboot
  8. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    This might be stupid, but have you tried the F12 button? It often helps to hold it down for a couple seconds if it doesn't work at first try...
  9. crees! macrumors 68000


    Jun 14, 2003
    Make sure also to try the mouse button on the track pad. So unplug your normal mouse and try that way. All of these ways are found in Apple's support pages.
  10. PBGPowerbook thread starter macrumors regular

    Jan 6, 2004
    None of these methods have worked. This computer doesn't have an emergency eject paper-clip hole, I think. Any other ideas?
  11. reaper macrumors 6502

    Apr 9, 2004
    19th Hole
    Wow... even booting into open firmware?!? I would say take it into a tech and see what the problem is, since it doesn't seem like you're going to be able to get it out without doing some demolition. :(

    - reaper
  12. LaMerVipere macrumors 6502a


    Jan 19, 2004
    And none of the methods given WILL work.

    I had this exact same problem happen to my old 12" PowerBook G4 (867MHz), and apple talked me through all the tricks and booting up into firmware and all that jazz and nothing worked and I eventually just had to send it in to them to get fixed.

    You are going to have to go an Apple Store near you or an authorized apple reseller to have them fix it or send it off to apple. Nothing else you can do will work to get it out.

    It happened to me a week after I bought my PowerBook so I just sent it in and they sent me back a new machine, but they will likely just repair yours. Be warned, you probably won't get your CD back, I didn't.

    Call up AppleCare or go to an apple store if its still under warranty, and get the ball rolling asap!
  13. dswoodley macrumors 6502a

    Jul 18, 2002
    When I had the exact same problem, it took me four tries booting into the firmware to get it to work, but eventually it did..

Share This Page