Preferences not being written/updated

Discussion in 'Mac Help/Tips' started by Codemonkey, May 13, 2003.

  1. Codemonkey macrumors 6502

    Apr 22, 2002
    Hi all,

    I'm having a problem with some of my apps not rememebring their new preferences. For example, in Word X, if I add a new Template to the templates folder, it doesn't get picked up on launch of Word.

    As well, my Terminal doesn't remember any of my customizations.... window color, transparency, fonts, etc.

    But SOME apps DO seem to retain their new prefs.

    Also, after a reboot, my Finder windows forget about their 'sort by' order, size and position on screen.

    Any help?? I've tried to compare permissions to a fresh install of 10.2.6 I have on my Pismo, and so far it doesn't seem tha tthat is the culprate, unless I'm looking in the wrong spot...

    Any advice would be super.
  2. mnkeybsness macrumors 68030


    Jun 25, 2001
    Moneyapolis, Minnesota
    when you change the window settings in the terminal, are you clicking the "use settings as default" button at the bottom of the settings window?
  3. Codemonkey thread starter macrumors 6502

    Apr 22, 2002

    It's ticking me off. I'm wondering if my user is corrupted somehow...
  4. benixau macrumors 65816


    Oct 9, 2002
    Sydney, Australia
    just trash the prefs of the apps that are having probs. i know it is a pain but it is better than windows - you would have to re-install your OS unless you know how to delete 360 odd registry keys.
  5. Rufus macrumors newbie

    Mar 2, 2003
    Wichita, KS
    And try repairing permissions using Disk First Aid. That solved a lot of problems I was having with preferences and internet cookies.

    If that doesn't work, we can look at your user in NetInfo. I've actually seen OS X change a user id to an invalid number and the resulting problems were similar to what you described.

Share This Page