printer blues

Discussion in 'Mac Help/Tips' started by janey, Mar 14, 2003.

  1. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    my choir director's using an epson printer with her outdated graphite iMac running OS 9.1
    However, when she tried to print, the comp would say "LaserWriter" instead of the Epson printer and when you try to print something in AppleWorks it says some weird and cryptic message i don't remember about the printer not existing.
    When i took a look at the system profiles, the computer recognized the Epson printer on the USB port but kept saying that the printer was the LaserWriter.
    I thought perhaps i could find a fix online, however none of the computers nearby were connected to the network or to the internet. Cell phone reception in her room was even worse so I couldn't use my mac.
    To print the documents we transferred the documents from one iMac to my AluBook which had no problem with the printer but we can't use this temporary fix forever.
    Anyone know what I can do to fix the problem?
  2. timbloom macrumors 6502a


    Jan 19, 2002
    try to remove all the printer extensions that she does not need, especially the one that interfering, then see if there is still a problem. If so, the printer extension for the epson is probably corrupt.
  3. rainman::|:| macrumors 603


    Feb 2, 2002
    download the driver to your 'book

    copy it over

    reinstall the print driver.

    i'd guess it's simply corrupt. or incomplete, there could be some extension file missing... also, the installer should provide you with some sort of utility that can help troubleshoot problems--

  4. janey thread starter macrumors 603


    Dec 20, 2002
    sunny los angeles
    that's what i thought...but i can't find the right driver so i'm stuck.
    I guess I'll try your tips thanx!
  5. janey thread starter macrumors 603


    Dec 20, 2002
    sunny los angeles
    *banging head on table*
    *banging head into keyboard*
    *banging head on heatsink*
    The printer still doesn't work and i swear to god i already tried everything you guys told me...
    There was another printer that i managed to get working (damaged USB cable).
    Tomorrow i'm installing Jaguar on the iMac, before i do that can you guys give me more things to try?
  6. Eniregnat macrumors 68000


    Jan 22, 2003
    In your head.
    RE: OS 9.x Printer blues.

    I posted this on this link.

    Strydent Software makes Power Print , a program and cable designed to get legacy printers to work. (Including the NEC-ss-870 ) From what I have found, your printer has a parallel port, so this product might help. I have used PowerPrint for years, and it works for me. This is not an OSX app.

    PowerPrint is good. It also adds new functions and options for printing (on some printers inverse, ink/toner save, dithering, scaling, etc..)

    Also, check the printer cable- actualy start there. I have had more than one USB cable go bad.

    Upgrading a person to OSX is not always the best thing. LAG (Latest And Greatest) is not always the best solution, especially if they are happy, familiar, and have no real need to upgrade to a new OS and apps.

    Power Print-
  7. yzedf macrumors 65816


    Nov 1, 2002
    to bad you didn't have floppy drives eh?

    tell your teacher to get a cheapo usb memory keychain, save the file on it, and print it somewhere else.

    dual boot set-up sounds good though. OS X is here to stay.

    where is the CD that came with the printer?
  8. janey thread starter macrumors 603


    Dec 20, 2002
    sunny los angeles
    there are no cd's to anything that this school owns :rolleyes:
    Installed Jaguar on that iMac, everything now works...great because i really wanted to get those 9gb worth of files and crap off my laptop :)
    thanx guys!
    now i need to laugh at the yearbook commitee's powerpoint presentation and how it crashed because the windoze laptop couldn't handle windows xp because it was so outdated :p

Share This Page