Printing to Epson Stylus Pro 7800 from OSX 10.6.2 via SP781W MFP Server

Discussion in 'Mac Accessories' started by Caterham, Mar 9, 2010.

  1. Caterham macrumors newbie

    Caterham

    Joined:
    May 20, 2009
    Location:
    Essex, UK
    #1
    I'm at the end of my tether.

    Have set up the Print Server with an IP on the wireless network. I can print to it just fine from Bootcamp XP using the normal Epson Driver. Can't for the life of me get it to work through OSX using the same IP through LPD protocol. I just get a communication error. I've tried using the Epson driver and the GIMP drivers but no luck. Can't check ink levels either but I'd expect that. Any ideas? I've had this problem for a few days now and the 50 quid print server is going to get smashed very soon!
     
  2. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #2
    Have you tried following the installation instructions on page 139 of the manual?

    http://www.micronet.info/up_images/english/12/492/SP781W Manu.pdf

    I'm unfamiliar with your particular MFP print server, but I know that for my print server I needed to install a Mac OS X program to be able to print and scan with my Epson RX595. The program opens a connection with the printer, allowing my computer to communicate with it as though it was connected via USB. My particular model is the ZyXEL NPS-520, but since ZyXEL has next to no Mac support, I had to flash it with Edimax's PS-1206MF firmware and use their OS X software to get it to work properly.
     
  3. Caterham thread starter macrumors newbie

    Caterham

    Joined:
    May 20, 2009
    Location:
    Essex, UK
    #3
    Yeah set it up exactly like the manual suggested. No joy.
     
  4. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #4
    The print server supports "standard" network protocols - but not the redirection of USB from computer to server device (like skorpien was talking about). To use "standard" protocols, you need a driver that uses the standards. Epson's driver for USB-only printers is a USB-only driver. You need a CUPS driver - like Gutenprint (included in OS X). If your model isn't already in OS X, try updating Gutenprint.
    http://gimp-print.sourceforge.net/MacOSX.php

    Or, consider printfab:
    www.printfab.net
     
  5. Caterham thread starter macrumors newbie

    Caterham

    Joined:
    May 20, 2009
    Location:
    Essex, UK
    #5
    Yeah I've used the latest Gutenprint drivers. Unlike the Epson driver which just gives me back a communication error, the Gutenprint one just tells me that the printer is paused. Definitely something getting lost in translation somewhere down the line I reckon.
     
  6. chazza macrumors newbie

    Joined:
    Sep 28, 2010
    #6
    Edimax frustration

    @Skorpien
    I have a PS-1206 which I can print to from vista laptop but I can't get it to work in OSX. The Server Manager and MFP manager are up and running, settings same as windows, but when I try to add the printer in "Print & Fax" I can't figure out what settings to use. There is no default to select so I tried lpd with and without queue names ("Port 1" ?) but no luck.
    Can you help me please ?
     
  7. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #7
    Are you able to connect to the printer using the MFP manager in OSX? When I installed mine, all that was necessary to add the printer was to connect to it from the MFP manager and add it in the Printer Preferences. It detected it as it would if it were connected via USB.

    Also, have you changed the IP of the Edimax server from the default to something that's within your router's DHCP range? I think the default is something like 192.168.2.1 or something, and mine wouldn't work until I changed it to something in line with my AEBS network (10.0.1.XXX).
     
  8. chazza macrumors newbie

    Joined:
    Sep 28, 2010
    #8
    Hi, thanks for answering.
    Yes I can connect ok in MFP manager. Can ping the server also 192.168.0.66 255x3 . When I go to add printer nothing appears ?
    So for you it just appears as a connected USB printer ?
     
  9. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #9
    I honestly have no clue what it is that I've done differently from you to be able to add my printer. Have you installed the latest drivers for your printer? Connect it directly and add it to your printers to make sure everything is installed properly, then delete it and try again to connect to it using the print server. Also, are you running any antivirus or firewall programs? What version of MFP Manager are you using? Mine's 1.0.7.0 (I downloaded it directly from their support site).

    I'll post a couple of screenshots to show you the steps involved in adding mine. The first shows me connecting to the printer from the MFP Manager and the second shows the Add Printer dialog once it's connected.
     

    Attached Files:

  10. chazza macrumors newbie

    Joined:
    Sep 28, 2010
    #10
    Ok cheers. I'm using the same version of MFP. I had the printer connected directly at one point but I'll try again, see if that will make any difference.
     

Share This Page