Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Problem with Movies on iPad/iPhone and iOS 14

donawalt

macrumors 6502a
Original poster
Sep 10, 2015
556
244
I have discovered and found a possible solution to a problem I have been having with "Home Movies" through the Apple TV app on my iPhone 11 Pro Max and iPad Pro 2018. I am wondering if I am missing anything, or there is a reason this problem happened.

I have had about 10 mp4 files, categorized as "Home Movies" in Apple TV app, for about 5 years. Originally they showed up in iTunes, now they show up in Apple TV. The problem is this - I have audio but no video! This just started happening within the last few months, as it's been that long since I looked at any of them. I suspect it's iOS 14 but I don't know for sure.

These mp4 files are all downloads of presentations from YouTube. I tried re-downloading 1 or 2 again to see if they were corrupted. I also tried playing them on my Mac in Apple TV, Handbrake, and QuickTime - they all played with no problems. This problem occurs whether I have them categorized as Home Movies or just Movies, in which they show up with commercial movies I have bought.

I suspected a format or encoding problem or bug; here is how they are encoded:

Ctrl-I/info on the file says 640 x 480, AAC, MPEG-4
Handbrake adds H.264, 30 FPS FBR, AAC, Stereo; Filters: Comb detect, Decomb
Apple TV on the Mac adds encoded with LavF 53.18.0, total bit rate 1320 kbps (some of the files are 484kbps)

After trying the things I noted above, as a test I opened one of the files in Handbrake, and encoded it using the preset 'Apple 2160 p60 4K HEVC Surround', video encoder: H.265 (x265). I don't know much about this, I am sure that was overkill as these are simple SD stereo files, but I saw something on an Apple support page recommending H.265. I removed the old file from the movie library, and added the new one, and it works on both iPad and iPhone!

So, I am left with number of questions lol - do I need to do this with the other movies? Is there a better way that I should fix this? Is something in those files not supported any more? Is this a bug I should report? Why did this stop working after years, even on the same iPad?

Thanks for your help!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.