iPhone Problem with thumbnails in app switcher

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
Hello,

I've found this annoying issue in the app switcher, where I press the home button twice and then I see a very old thumbnail of the Mail app. And by that I mean that iOS doesn't actually show the current state of the app, but instead it shows a frigging old thumbnail (and it's always exactly the same one!).

The weird thing is that this happens only with the Mail.app preview, and not other applications. Also it doesn't happen always, but often.

Is there anything I can do to avoid always seeing the same contact card when I want to reopen Mail?
 

Stuke00

macrumors 68000
Oct 11, 2011
1,674
74
Collinsville,IL
Hello,

I've found this annoying issue in the app switcher, where I press the home button twice and then I see a very old thumbnail of the Mail app. And by that I mean that iOS doesn't actually show the current state of the app, but instead it shows a frigging old thumbnail (and it's always exactly the same one!).

The weird thing is that this happens only with the Mail.app preview, and not other applications. Also it doesn't happen always, but often.

Is there anything I can do to avoid always seeing the same contact card when I want to reopen Mail?
I just checked mine. The thumbnail updates just fine for me.
 

iolinux333

macrumors 68000
Feb 9, 2014
1,798
73
The same has been happening to me more and more lately - I just figure 7.1 will fix the problem and I can tolerate it until then.
 

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
The same has been happening to me more and more lately - I just figure 7.1 will fix the problem and I can tolerate it until then.


Mine shows old thumbnails also.



Wait for 7.1 in a few days.

Well, I'm on 7.1 now – and guess what? The issue is still there, and I'm seeing the same old thumbnail on Mail again.
 

CutterSlade

macrumors regular
Mar 13, 2014
161
0
Istanbul, Turkey
Updating the thumbnails you see in the app switcher is the apps responsibility, not the OS's. The OS itself updates the state only when the app is about to be closed.

But if the thumbnail shows a state older than the last one you've seen when the app was open, then there is a problem.
 

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
Try common measures. Close the app - restart the phone etc. If none of those pan out, you may have to restore.
Well, I already tried the obvious ones. I've closed Mail.app hundreds of times. The same thing restarting the phone. However, I want to find a workaround before going nuclear. Restoring the phone just because of this seems kind of killing a fly with an RPG.

Updating the thumbnails you see in the app switcher is the apps responsibility, not the OS's. The OS itself updates the state only when the app is about to be closed.

But if the thumbnail shows a state older than the last one you've seen when the app was open, then there is a problem.
Which is exactly what I said it was happening. ;)
 

CutterSlade

macrumors regular
Mar 13, 2014
161
0
Istanbul, Turkey
Which is exactly what I said it was happening. ;)
Yeah, I thought so, but wanted to check anyway:)

Btw, I've never seen that kind of problem go away after restarting the device or making a full restore. I suggest you to search the web thoroughly to see if someone else is having the same issue before restoring.
 

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
Yeah, I thought so, but wanted to check anyway:)

Btw, I've never seen that kind of problem go away after restarting the device or making a full restore. I suggest you to search the web thoroughly to see if someone else is having the same issue before restoring.
So at least you've seen this bug on other phones, right? It's always nice knowing that I'm not the only one suffering. :D
 

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
No, unfortunately not. I don't even use the mail app, so you might as well be the only victim of this issue:D
Since when does this happen?

Oh, my bad. Since you said "I've never seen that kind of problem go away …", I thought you've seen that kind of problem a few times.

Anyway. It happens since I installed that trojan called iOS 7.
 

iRock1

macrumors 6502a
Original poster
Apr 23, 2011
996
96
Just to give you a little update on this, now I face this problem all the time on iOS 7.1, on my iPhone AND my iPad, with Mail and basically any other app.
 

iwan073

macrumors 6502
May 1, 2011
256
15
The Netherlands
Sorry to bring this old post up, but I’m having the same issue.

One of my apps, I forgot which one, keeps showing a thumbnail from a long time ago. Weird thing is, it shows only this awkward picture in landscape mode. Not in portrait.

Come to think of it, WhatsApp shows an old screenshot/thumbnail too in landscape mode...

Is there a way to delete those thumbnails?
Cause the OP never got his answer...