Problems with autosave


macrumors newbie
Original poster
Nov 21, 2011
I know this has been discussed before, but I do not have a clue about computers, and I am afraid the other answers given just confused me more.

I have a macbook pro, it is running the latest version of Lion, and all I am trying to do is to work with a spreadsheet in Numbers. Every time I type a letter, or move to a different selected cell, it autosaves (or does a Version or whatever, that was the point the other threads lost me). It comes up with a progress box saying "Saving". Until it has finished this, I cannot type the next letter. This is taking me forever, and I have work to do!

I have tried to read the other threads, I really have, but at the point when they descend into arguing over whether people are talking about "Autosave" or "Duplicate" or "Resume" I get lost. I just want to stop it saving every letter I type, so I can just get on with it!

Please help me!


And this is in the wrong forum. Fantastic.



macrumors 6502a
Sep 18, 2011
Las Vegas, NV
hey Becki, its really stupid that apple doesn't allow you to configure autosave... really stupid. This has actually caused lion to be banned from a number of companies because its not configurable and it was destroying data on networked file systems.

Something you can try is to lock the document until your ready to save it. You should be able to lock through either the finder or on the title bar next to the document name. It adds another annoying step to your workflow, but it should help. Lion adds lots of those unnecessary steps just to do what you were able to do just fine before Lion.

Another option is to use OpenOffice or Microsoft Office apps that don't support the forced autosave feature yet.


macrumors 65816
Apr 25, 2007
Apple should have included the option to turn the whole Autosave/Versions thing off. It is annoying and very much drags the systems performance down.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.