Problems with iMessage...

Discussion in 'iPhone' started by bdzer, Dec 12, 2011.

  1. bdzer macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #1
    I'm having a problem, maybe I just don't know how to use my phone well..

    I try to create a new iMessage to someone or make it as a group, I enter my Text Message app and click the new message button at the top right, my iMessage contacts don't appear on there when I search for them and it is making a new text message. Does anyone know how to change this or make a new iMessage to a person/group?
     
  2. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #2
    /facepalm.

    Your contacts use their apple ID and or phone numbers as their iMessage address. There aren't "iMessage contacts", your phone automatically determines this while attempting to send a text.

    This is all explained in the user manuals.
     
  3. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #3
    I already have iMessage chats open with some of my friends but when I try to open a new one it's a Text Message. Am I misinterpreting something? Did I put their e-mail in a bad category or something?
     
  4. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #4
    That would mean (I'm just assuming here) that they are unavailable for iMessage.
     
  5. digitard macrumors 6502a

    digitard

    Joined:
    Sep 15, 2004
    Location:
    Gilbert, AZ
    #5
    I just load all my iMessage contacts as the iPhone listing, and it seems to always go to iMessage that way unless I turn it off.
     
  6. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #6
    They are available :(

    I wanted to make a group iMessage, which I did, but I had to delete the whole conversation with one of my friends then go into my contacts and click their contact to finally press Send Message and it opened up a 'New iMessage' instead of 'New Message' (Text). The only way I can iMessage someone is to go into contacts and I can't make a new iMessage directly from the Text app.
     
  7. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #7
    I haven't found the solution, my iMessage works fine, I just can't make a new iMessage as it is always a text message.
     
  8. sweetbrat macrumors 65816

    sweetbrat

    Joined:
    Jun 17, 2009
    Location:
    Redford, MI
    #8
    Are you sure that all people that you're trying to send to have iOS5 and have iMessage turned on?
     
  9. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #9
    i do know that certain people you iMessage with and your phone still has that info in memory, it will have a nice symbol to show you if they have iMessage enabled when starting a new text.

    [​IMG]
     
  10. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #10
    Yeah, they do.

    If it helps, I iMessage them using their Apple ID E-Mails and not their phone numbers because they are in Australia and Canada.

    ----------

    Your screenshot shows the @ sign, and the ability to type in .'s but when I go to make a new message mine does not. My iMessage works though as I have a few conversations open with other people.
     
  11. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #11
    Does anyone have the same problem as me? I can't type .'s or @'s when trying to create a new message.
     
  12. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #12
    On iMessage, where they are located doesn't matter. It's still only data use, if it sends via iMessage.
     
  13. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #13
    I know it does not matter.
     
  14. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #14
    Mine shows the @ and . when i'm typing in the "To:" part of the message. Once i switch to the body of the message and what is actually going to be sent, then it switches to just a space bar and those two buttons go back to where it normally was after you press the "123+" button

    EDIT: also in my original message i was talking about the little blue bubble next to the first contact
     
  15. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #15
    I have the blue bubbles only when I go into Phone -> Contacts -> Send Message, that's the only time I can make a new iMessage, I cannot make one directly in the Texting app.
     
  16. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #16
    well that's just weird. I'd try backing up your phone and doing a restore just to see if it helps
     
  17. bdzer thread starter macrumors member

    Joined:
    Oct 15, 2011
    Location:
    Washington
    #17
    I might try when I have the time to restore. :(
     

Share This Page