Problems with iMovie, manpath.config, Mail and Safari

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by bmarston, May 17, 2004.

  1. bmarston macrumors newbie

    Nov 3, 2003
    Saint Louis, MO
    A couple of days ago, my 15” PowerBook running Mac OS X 10.3.3 (Panther) was working fine. Now it’s not. The only unusual things I remember doing were trying to install Firefox (it hung the first couple of times I tried to run it, so I deleted it) and quitting during a reinstall of Bluefish using FinkCommander.

    Here are the problems I’m having, in the order that I noticed them:

    When I try to run iMovie 3.0.3, it crashes during startup. ~/Library/Logs/CrashReporter/iMovie.crash.log reports:

    Exception: EXC_BAD_ACCESS

    system.log says, “iMovie could not be launched prebound.”

    I tried to run iMovie from Terminal and got a “Segmentation fault” error.

    I issued a “sudo update_prebinding -root / -force” command, but iMovie still crashes on startup. I also renamed ~/Library/Preferences/, and that didn’t fix the problem either.

    When I start Terminal, I get an error message that says, “manpath: unable to make sense of the file /etc/manpath.config”. /etc/manpath.config contains a bunch of binary junk.

    When I try to open a message that has an attachment in Mail, I get the Spinning Beach Ball of Doom. Mail’s CPU usage soars to the mid-90s, it hangs, my laptop gets really hot and eventually the whole machine locks up. I’m unable to kill the Mail process using Force Quit or the command line. I end up having to pull the plug and take out the battery to get it to shut down. This happens for any kind of file attachment. I’m able to open messages that don’t have attachments without a problem.

    I ran “Repair Disk Permissions” using Disk Utility. That didn’t fix any of the above problems. I ran the Apple Hardware Test on the Panther installation DVD. Everything passed.

    Now Safari has started locking up. Right after I open it, I get the spinning beach ball. I’m unable to force Safari’s process to quit.

    At this point, I’m afraid to even turn the machine on. Does anyone have any suggestions? I bought it in December 2003. It’s my first Mac.
  2. bmarston thread starter macrumors newbie

    Nov 3, 2003
    Saint Louis, MO


    I got everything working again. Here's what I did:

    1. Restarted with a safe boot, followed by a regular boot
    2. Booted from the installation DVD and used the Disk Utility to "Repair Disk"
    3. Reset PRAM and NVRAM

    At that point, Safari seemed happy. Next, I did the following:

    4. Downloaded and installed OnyX
    5. Cleared my system and user caches
    6. Manually edited /etc/manpath.config to look like this:

    # $FreeBSD: src/gnu/usr.bin/man/manpath/manpath.config,v 1.18 2002/03/23 00:04:15 brian Exp $
    # This file is read by manpath(1) to configure the mandatory manpath,
    # optional manpath and to map each path element to a manpath element.
    # The format is:
    # MANDATORY_MANPATH                     manpath_element
    # OPTIONAL_MANPATH                      manpath_element
    # MANPATH_MAP           path_element    manpath_element
    # MANLOCALES            locale1 locale2 ...
    # every automatically generated MANPATH includes these fields
    MANDATORY_MANPATH       /usr/share/man
    # check if the directory exists and if it does, add it to MANPATH
    # OPTIONAL_MANPATH        /usr/local/lib/perl5/5.6.1/man
    # set up PATH to MANPATH mapping
    MANPATH_MAP     /bin                    /usr/share/man
    MANPATH_MAP     /usr/bin                /usr/share/man
    MANPATH_MAP     /usr/local/bin          /usr/local/man
    MANPATH_MAP     /usr/X11R6/bin          /usr/X11R6/man
    # set man locales, if needed
    #MANLOCALES     ru_RU.KOI8-R
    That fixed the manpath.config issue. At this point, iMovie and Mail still weren't working for me.

    7. Logged in as a different user. iMovie and Mail worked fine for this user.

    8. When I restarted and logged in as me, iMovie and Mail worked.

Share This Page