Problems with iPhone Staying Connected While Syncing

Discussion in 'iPhone' started by pilotkid, Dec 21, 2008.

  1. pilotkid macrumors 6502a

    Joined:
    Aug 22, 2006
    Location:
    Chandler, AZ/Chicago, IL
    #1
    Is anyone having problems with their iPhone staying connected via the USB cable to their computer/iTunes? For some reason my iPhone keeps disconnecting and then reconnects instantly. So for example I'll plug it in to my MacBook and it will say "Sync in Progress" and it will show up in iTunes and begin syncing and then I'll hear the noise that it makes when you connect your iphone to have it charge and the syncing will stop and then it just reconnects to iTunes and makes the noise like i just plugged it in to charge again. It even disappears from the "Devices" Section in iTunes...Sounds really confusing but hopefully you guys understand what I'm trying to say...
    Thanks everyone, and Happy Holidays!!!

    PS. This doesnt happen EVERY time, but it happens a good 50%-75% of the time I try to sync my iPhone. What I'm trying to figure out is, is this a problem with my iPhone(Hardware) or is this a problem with the software...As we speak I'm in the process of resyncing everything because I did the complete erase and reset thing where it takes lik 2-3 hours to reset.

    Iphone: 16GB Black 3G
    Computer: Early 08 Black MacBook

    Thanks again.
     
  2. Slowstick macrumors 6502

    Joined:
    Dec 16, 2008
    #2
    I had this problem on my previous computer (a PC I should add).

    Just reinstall iTunes. That fixed my problem.

    I also heard if you delete the backups of your iPhone and then connect the iPhone again, it should solve your problem. I hope that made sense.:D:D
     
  3. DanielJvdBerg macrumors regular

    Joined:
    Jun 1, 2008
    Location:
    The Netherlands.
    #3
    I have the exact same problem. Problem is this: the dock connector is faulty. Mine is. I can connect it to speakers with a dock connector but it will not output sound anymore. Also when it's connected to a computer or a charger it randomly disconnects and then reconnects. I'm getting mine replaced, T-Mobile NL said it is a usual problem.
     
  4. istariphoenix macrumors member

    Joined:
    Jun 27, 2010
    #4
    Menothinksso

    Doubtful. My 4S is doing the same thing too, non-jailbroken, non-unlocked, with AT&T. Uber-frustrating. Ready to take this back in and exchange it. Tried everything: reboot, restore, delete backup, delete sync history, new cables, different ports, on iPhone dock (works better when it's on the dock for some reason), off iPhone dock, tried powered hub, tried regular ports, tried 2.0 ports, tried 3.0 ports, result is the same. Completely unpredictable, spontaneous, and without logic in any way, shape or form.
     

Share This Page