Problems with Warcraft III

Discussion in 'Games' started by spencecb, Mar 6, 2006.

  1. spencecb macrumors 6502a


    Nov 20, 2003
    Hi everyone. I was wondering if there are others out there that are experiencing the same problem I am with WC3...

    During gameplay, the system will completely lock up, not allowing any type of force quitting the application. The only way to recover is to hold down the power button and restart that way.

    Here are my system specs:
    iMac G5 2.1 GHz
    Mac OS X 10.4.5 (and it has been occuring through several OS X updates)
    WC3 1.20c
    I'm not sure what else is relevant info here?

    Now, before anyone starts asking if I have repaired permissions or have tried all possible key-combinations to get out of the WC3 window, the answer is YES x infinity.

    Blizzard's own website acknowledges that there is an issue with OS X. But the problem is, my system is not generating any crash log that I can find, so I just have no clue what is going on.

    There have to be others out there that this is happening to. Let me know what you have done to fix it. I have tried all the steps on Blizzard's site suggesting fixes except for the one that says turning off all the sound options, then turning them back on one by one until a crash happens again. I'm not willing to put all that effort into it, as I do not think this is an audio related issue.
  2. Ja Di ksw macrumors 65816

    Ja Di ksw

    Apr 9, 2003
    Wow, I haven't had that problem at all. Just got done winning a game, actually, and no lag. Crossing my fingers.

    Hope it works out for you, let us know if you fix it in case it happens to someone else in the future.
  3. haiggy macrumors 65816

    Aug 20, 2003
    Ontario, Canada
    My computer has never frozen while playing WC3 TFT 1.20c (or any other patches for that matter). I have had an issue before though (happened twice) that it would not run because OpenGL was apparently deleted from my computer or something. I had to reformat my computer lol But anyways, yeah that is a weird problem...

    So in response to your question: No, that has never happened to me before
  4. spencecb thread starter macrumors 6502a


    Nov 20, 2003
    Hmmm...I was hoping for more responses to this. It must be a bigger problem since Blizzard has acknowledged it.

    I can't remember when this all started...I know my Rev. A iMac G5 did not have this problem, but I'm pretty sure my PowerBook G4 started doing it at some point. It must have been caused by some sort of OS X update from Apple.
  5. benjuddeffect macrumors newbie

    Mar 8, 2006
    Osaka, Japan
    Sigh... Great computer, but this bug is frustrating...

    Hey, I am also encountering the exact same problem. I can play WC3 (my favorite PC game) on single player mode without any problems but everytime I try to connect to battlenet (just pressing the battlenet button) ends up locking up the computer.

    I've got a Macbook Pro 2.0 and the problem is still rearing its ugly head so I assume this is an OS X issue? If anyone has any updates on this I would love to know. Single player WC3 just isn't the same... :(
  6. DougTheImpaler macrumors 6502a

    Feb 28, 2006
    Central Illinois
    do you have hte OS X firewall enabled? you might be blocking the app from reaching the internet, in effect causing the lockup while it waits for some response?
  7. benjuddeffect macrumors newbie

    Mar 8, 2006
    Osaka, Japan
    No, unfortunately it would appear I do not have the firewall enabled.

    And on top of that I went to Blizz's page and set the port to 4000 like they suggested but that still didn't help. Thanks for the suggestion anyways.

    I guess a better question would be, is there anyone here using a Macbook Pro that has been able to play WC3 over Battlenet??

    Thanks for all your help.

Share This Page