Problems with Youtube videos, League of Legends, everything that is graphic intense

Discussion in 'MacBook Pro' started by 845Heaven, May 3, 2013.

  1. 845Heaven macrumors newbie

    Joined:
    May 3, 2013
    #1
    Hi all,

    This is my first post in this forum, so please excuse me if this post have come up before/I am doing something wrong.

    I have a Macbook Pro 2010 15 inch model (2.4GHz, GT330M graphics)
    I've had it ever since late 2010, and I have never had an issue like what I am experiencing right now.

    Recently (happened about 2 - 3 weeks ago), whenever I watch youtube videos on 720/1080p, the video becomes out of sync with the audio. What I mean by that is the audio is in the right timing, but the video keeps on chopping from one frame to another.

    I have tried to search for the solution (cleared cache, etc), but it seems that the only thing that solved this problem is restarting the computer. After I restart it, it can play youtube videos on any resolution without hiccups.

    However, very recently, while I play the game League of Legends, my framerate stays for 40 - 60 fps, and then very suddenly drops down to 10 - 15fps, and does not go over 15. I wondered if this problem is related to the youtube video problem, which seemed to be the case after I tried out a 720p youtube video immediately after I was finished with the game.

    Once again, my only solution was to restart the computer.

    Anyone had any issues with this? Whenever I go to say, bbc/cnet and try to watch the videos on HD, it is the same thing.

    Must I honestly try to reformat my laptop? It's going to take the whole day to just retrieve the data from the backup.... major pain.

    If anyone have encountered this problem before, and was able to solve it without reformatting your mbp, let me know.

    Cheers.
     
  2. B... macrumors 68000

    B...

    Joined:
    Mar 7, 2013
  3. ianwuk macrumors regular

    Joined:
    Dec 2, 2010
    #3
    I have a 2010 MBP too and have often had this issue as well (with movies being out of sync). For me at least it was because of uTorrent and my downloads using up too much resources. As soon as I quit uTorrent it went back to normal.
     
  4. 845Heaven thread starter macrumors newbie

    Joined:
    May 3, 2013
    #4

    The version is 10.7.5
     
  5. B... macrumors 68000

    B...

    Joined:
    Mar 7, 2013
    #5
    You can try an SMC Reset.
     
  6. 845Heaven thread starter macrumors newbie

    Joined:
    May 3, 2013
    #6
    Well I remember having NOTHING on the background when I was playing League of Legends. I also tried shutting down everything (including internet tabs) except for the 720p youtube video, but it still did not make a difference...:(

    ----------

    Thanks for the advice. I have just did the SMC reset.

    Something is definitely different.... for instance, the desktop wallpaper which I had applied several months ago (which was oddly replaced without my authorization several weeks ago to the default osx lion "milky way" wallpaper) came back.

    So something is definitely changed, and I will test it out and will let you know if there are any problems.
     
  7. 845Heaven thread starter macrumors newbie

    Joined:
    May 3, 2013
    #7
    Yup that fixed it.

    Thanks B!
     

Share This Page