Programs crashing in jaguar

Discussion in 'Mac Apps and Mac App Store' started by ezsober, Mar 17, 2004.

  1. ezsober macrumors member

    Aug 14, 2003
    As mentioned in a different threat, my mail program has been crashing more and more for various reasons, including attaching documents, attempting to view email with documents, and deleting documents.

    My browsers have been crashing (explorer/netscape) when loading popups, and even simply loading the page, including the new york times, of all things.

    My system preferences quits when I attempt to adjust various perferences.

    My screen effects doesn't work and crashes when I try to change the effect.

    More and more of my programs are simply crashing after being opened or after attempting the simplest of tasks.

    Someone in another thread suggested I archive and reinstall.

    Does anyone have any clue why more and more of my programs are wigging out?

  2. HexMonkey Administrator


    Staff Member

    Feb 5, 2004
    New Zealand
    Have you tried repairing permissions in Disk Utility?
    Have you tried creating a new user to see if the problem occurs there?

    If the problem occurs in one user only, then there will be corrupt file(s) somewhere in /Users/[Your username]/Library. An archive and install will not fix this because your user folder is not modified. Your options in that case are to create a new user and delete the old one, delete/move your user's Library or possibly Preferences folder (the Preferences folder is inside Library, deleting it will not necessary fix the problem but it is the most likely cause of problems in the Library folder), or to use trial and error to track down the corrupt files.
    If the problem occurs with multiple users, an archive and install will probably fix the problem.
  3. mklos macrumors 68000


    Dec 4, 2002
    My house!
    If it comes down the reinstalling Mac OS X.2 (Jaguar) then I WOULD NOT to an archive & install. Doing that only creates problems similar what your having right now. Back your stuff up somehow and do an erase and install. You'll be much better off.

    I would try what HexMonkey said. If non of those seem to fix your problem then I would do what I said above. It sounds to me like you just need to repair your permissions.
  4. ezsober thread starter macrumors member

    Aug 14, 2003

    Thanks for the suggestions. I repaired permission when the problems first arose last week, but the problems have only gotten worse.

    Actually, I just trashed my preferences, after making a copy, as suggested. The programs seem much more stable and I can use mail again. However, I lost all my settings, so moved my copied preferences back into the library to copy the relevant data. All the same preferences are still there, and nothing's crashing now...


Share This Page