Purchased ringtones from itunes not showing up after updating to IOS 5

Discussion in 'iOS 5 and earlier' started by Yellowsnow0, Oct 13, 2011.

  1. Yellowsnow0, Oct 13, 2011
    Last edited: Oct 13, 2011

    Yellowsnow0 macrumors newbie

    Oct 13, 2011
    After updating my iphone and my wifes iphone to ios 5, the ringtones we purchased from itunes no longer show up on the phone that they were purchased from. So her phone has Guns N roses ringtones, and mine has J-lo ringtones. We share an itunes account, they show up in itunes. It's almost like it thinks they are on the phone so it's not syncing them. All custom ringtones sync fine that I made from an app.

    If I purchase them again will itunes charge me? Or will it just re-download them?

    Thanks in advance for any help.
  2. thatisme macrumors 6502


    Mar 23, 2010
    United States
    if you re-download, they will re-charge you. Ringtones are not treated with fair use rules like music is these days.

    Re-Sync your devices to iTunes, make sure that ringtones and music is checked as things to sync for you, and they should then be available.
  3. Yellowsnow0 thread starter macrumors newbie

    Oct 13, 2011
    I've tried that... I've synced all ringtones, I've synced selected ringtones and it all works fine except for the ones purchased thru the phone.
  4. MacBreezy macrumors regular


    Sep 26, 2011
    Charlotte, NC
    I had this issue as well. Downloaded some new Alert tones that are entertaining but when I synced my phone none of my old ringtones would sync. I'm guessing they are not IOS 5 compatible?
  5. RyanCrazy macrumors newbie


    Aug 3, 2010
    un-check the option to "sync ringtones", then sync your phone, then re-check "sync ringtones" and re-sync... all your ringtones should now be on your phone.
  6. xeqshunr macrumors member

    Feb 3, 2011
    Still not working

    I'm having the same trouble. Unsynched all ringtones. Resynched all ringtones. nothing.
  7. Robo6675 macrumors newbie

    Apr 12, 2011
    I was having this problem when plugging in my phone but it worked when I did over wifi sync. Possible just a coincidence...

Share This Page