Pwnage iPhone 3G, 5.12.01, jailbreak/unlock to 4.2.1

Discussion in 'Jailbreaks and iOS Hacks' started by SavMBP15, Nov 29, 2010.

  1. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #1
    Pwnage 4.1.3 is out and there is a tutorial on iClarified located here.

    My question is for my iPhone 3G, 3.1.3, with modem baseband 5.12.01 and wanting to upgrade to 4.2.1 can I do this and preserve my baseband?

    The tutorial states:
    If you are on the 05.14 or 05.15 baseband you will also need the iPad 3.2.2 firmware. You can find out how to determine your baseband version here.

    Then at step 6 it states:
    Step Six
    You will now be asked if you want to update your baseband to the 06.15 version. If you are on 05.14 or 05.15 or higher you will need to do this to unlock. You do not need to do this for jailbreak only.


    Then at the unlock tutorial located here, it states:
    This will work with the iOS 4.2.1 firmware if you are on the 06.15.00 baseband. Before you can follow these instructions you must have a jailbroken iPhone and you must be on the 04.26.08, 05.11.07, 05.12.01, 05.13.04, 06.15.00, or 01.59 baseband(modem firmware).

    Seems to contradict itself between the two statements, or at the very least is not very clear.

    So I'm not on baseband 05.14 or 05.15, does that mean the unlock will still work without doing the iPad baseband?

    If I upgrade, can I downgrade back to 3.1.3?

    To do that does it matter if I have my SHSH saved? (I do btw)

    Thanks,
    Matt
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    Step #6 you should click NO to updating the baseband since your current 5.12 baseband is already unlockable with Ultrasnow.
     
  3. lucifiel macrumors 6502a

    lucifiel

    Joined:
    Nov 7, 2009
    Location:
    In your basement
    #3
    First, iOS 4.2.1 will be a tethered jailbreak, but I will assume you know this.

    Second, baseband 05.12.01 should be unlockable without needing to upgrade to 6.xx.xx so you just need to update the iOS without updating the baseband.
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    It's untethered on 3G (OP has) and 3GS old bootrom.
     
  5. iphonegeek786 macrumors 6502

    iphonegeek786

    Joined:
    Nov 18, 2009
    #5
    I have the same question, so I just go to the new pwnage tool, put in the ipsw for 4.2.1. Then I uncheck upgrade baseband, and then I should be fine?
     
  6. Slipx macrumors newbie

    Joined:
    Dec 1, 2010
    #6
    Has anyone managed to install 4.2 on a 3G and preserve there older unlock able baseband using this method
     
  7. jw74 macrumors member

    Joined:
    Mar 15, 2009
    #7
    Same question. Can I keep my baseband?
    I have a 3G, baseband 05.13.04. Currently unlocked on 4.0.2. But I can't stand how slow it is.
    Also, are there any other concerns when doing this upgrade/JB/unlock?
    Thanks
     
  8. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
    #8
    u need to use pwnage tool to create a custom ipsw, then use redsn0w to install cydia and jailbreak it. Lastly install ultrasn0w to unlock it. This is for the 3GS, I'm not sure if on the 3G u only use pwnage tool.
     
  9. dthree36 macrumors regular

    Joined:
    Feb 4, 2008
    #9
    Any luck with applying a 4.2.1 ipsw

    So... has anyone used the method in this post. I can wait to upgrade but I am getting a bit anxious but want to retain my baseband.
     
  10. jw74, Dec 6, 2010
    Last edited: Dec 6, 2010

    jw74 macrumors member

    Joined:
    Mar 15, 2009
    #10
    I did it following these directions:
    http://www.iclarified.com/entry/index.php?enid=13000

    I kept my baseband.
    It worked. The only problem being that springboard crashes when doing app switching when in an app. So I switch apps only from the springboard. A minor annoyance, but I quickly got used to it.
    There is a fix, but it's over my head.
    I'm not sure if this is a problem caused by jb/unlocking a 3G on 4.2.1 or it's just a problem with a 3G on 4.2.1 in general.
     
  11. WiiDSmoker macrumors 65816

    WiiDSmoker

    Joined:
    Sep 15, 2009
    Location:
    Hermitage, TN
    #11
    Did you enable multi-tasking on the 3G?
     
  12. jw74 macrumors member

    Joined:
    Mar 15, 2009
    #12
    I did.
     
  13. WiiDSmoker macrumors 65816

    WiiDSmoker

    Joined:
    Sep 15, 2009
    Location:
    Hermitage, TN
    #13
    That's your problem with Springboard crashing
     
  14. slix88 macrumors newbie

    Joined:
    Dec 11, 2010
    #14
    Windows version?

    Hi All,

    I came across this thread via google and I'm in desperate need of assistance regarding an upgrade to FW 4.2.1.

    I've been on FW 3.1.3 for a while but now I'm getting plenty of problems with my 3G connection (possibly software related) and really am looking forward to upgrading to the newest JB available.

    I have looked at plenty of reviews online, including the redsn0w, but the first step involving the update to the latest iOS through 4.2.1 doesn't make sense. It states:

    "RedSn0w was recently updated to jailbreak iOS 4.2.1. While this is excellent news, it doesn’t come without its drawbacks as only the iPhone 3G, older iPhone 3GS, and non-MC iPod touch 2G get the untethered jailbreak."

    I'm on baseband 05.12.01 at the moment. By updating to 4.2.1 on itunes, wouldn't that also update my baseband, thus eliminating the use for the older firmware?

    My phone is factory unlocked and I would like to know of the easiest way I can obtain an UNTETHERED 4.2.1 JB without the need to update to the stupidly pointless iPad firmware. Unfortunately, I cannot use QuickPWN since it is MAC based to cook a new firmware with the old baseband.

    Any other alternative? Any help will be much appreciated.

    -Simon
     
  15. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #15
    JB 4.2.1 is untethered for 3G iPhones. And, since you have a factory unlock iphone, it will forever be unlock no matter what official baseband it's running. You dont have to worry about whether to update or try keeping the current baseband. Just update to 4.2.1 with itunes and use latest version of Redsnow to JB.
     
  16. slix88 macrumors newbie

    Joined:
    Dec 11, 2010
    #16
    So you're basically saying that I can update to the new iOS through itunes, apply redsn0w WITHOUT allowing for update to ipad firmware and I can still use my phone untethered?

    I was under the impression that the baseband had something to do with the tethering. Wouldn't I get the DFU screen if I restart my phone with the new baseband on the new JB?
     
  17. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #17
    The baseband has only to do with being able to unlock or not. Since you have a factory unlock phone, you never have to worry about what baseband you have. Thus, you don't need to use iPad baseband.

    Whether it's a tethered or untethered has to do with JB method. For 3G iPhone, it will be untethered 4.2.1 JB with Redsnow. Just use iTunes to update to official 4.2.1 firmware then run Redsnow to JB the phone. It's that simple when you don't have to worry about keeping tue baseband.
     
  18. slix88 macrumors newbie

    Joined:
    Dec 11, 2010
  19. jodtee macrumors newbie

    Joined:
    Dec 14, 2010
    #19
    Is there anyone, who tried the Pwnage-way discribed above. I would love to have 4.2.1 and keep my old unlocked BB.

    Please report…
     

Share This Page