Pwnagetool 3.1.4 on a 3GS on ATT - failing to activate

Discussion in 'Jailbreaks and iOS Hacks' started by tsg20, Dec 12, 2009.

  1. tsg20 macrumors member

    Joined:
    Jul 25, 2007
    #1
    I'm having trouble jailbreaking my 3GS (on ATT). I was starting from 3.0.0. I've used pwnagetool (multiple times) to create a custom 3.1.2 ipsw with activating *not* checked, and have restored to these files, either to old backups or starting completely from scratch. Every time, I have a jailbroken phone running 3.1.2 with the modem firmware still showing as 04.26.08, but I never get a signal, and in settings/general/about it has "Not Available" for network and carrier. What am I doing wrong?! Everything seems great apart from the fact that the phone component is no longer working.
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    Have you actually tried making a call? Phones with 3.1.2 and 4.26.08 have an issue with the carrier logo not showing up which doesn't really affect service. You can get your carrier logo back by installing ultrasn0w from Cydia.

    In any case, if you can get into your phone and check your baseband version, your phone is definitely activated.
     
  3. tsg20 thread starter macrumors member

    Joined:
    Jul 25, 2007
    #3
    I tried one more time, and this time it did something different - it told me there was a carrier update. Lo and behold, it actually works now! I was then able to restore from an older backup to get all my settings working. I was a bit confused about the lack of an AT&T logo, so thanks for clearing that up.
     

Share This Page