PwnageTool 4.0 has been Released to Jailbreak iPhone 3GS on iOS 4 [Official]

Discussion in 'Jailbreaks and iOS Hacks' started by SocialMedia, Jun 22, 2010.

  1. SocialMedia macrumors newbie

    Joined:
    Jun 8, 2010
    #1
    The iPhone Dev Team has just released PwangeTool 4.0 To Jailbreak iOS 4 for iPhone 3GS but with Old BootRoom, This Jailbreak don't support iPhone 2G, iPhone 3G and iPod Touch 2G. You can Now Easily Jailbreak your iOS 4, iPhone 3GS on Old BootRoom using PwangeTool 4.0 Then Unlock it using Ultrasn0w 0.93 which was released yesterday by Dev Team.

    [​IMG]

    Here's the post in the iPhone Dev Team Blog:
    NB: With PwnageTool 4.0 certain devices are not supported this is because they are not supported in iOS 4.0 or they are not supported by our software.

    * iPhone 2G - not supported
    * iPod Touch - not supported
    * iPod Touch 3G - not supported

    iPhone 3G

    * If you have a Jailbroken iPhone 3G at 3.1.2 (but not jailbroken with Spirit) then you should create the ipsw with PwnageTool 4.0 and restore from recovery mode or DFU mode.
    * If you have an out of the box iPhone 3G you should restore using a PwnageTool 4.0 ipsw using DFU mode.
    * If you have a Jailbroken 3.1.3 iPhone 3G it is very possible that this can fail from recovery mode, if this failure happens you will need to restore using DFU mode.

    IMPORTANT! Whenever you need to enter DFU mode, you will need to do so using PwnageTool.

    iPhone 3GS

    Summary: PwnageTool only works on previously jailbroken 3GS devices with the old bootrom.

    * If you have a Jailbroken iPhone 3GS with the OLD BOOTROM and you DID NOT use Spirit to jailbreak then you can create the ipsw with PwnageTool 4.0 and restore with recovery mode.
    * If you have an iPhone 3GS with the NEW BOOTROM this is NOT supported by PwnageTool 4.0

    iPod touch 2G

    * If you have an iPod touch 2G that is jailbroken (but not with Spirit) then you can restore using recovery mode.

    Baseband Unlock

    * iPhone 3G and 3GS baseband unlockers (those who rely on ultrasn0w to make phone calls) should always be very wary to update their firmware, however our Ultrasn0w application will unlock all recent (including the current) 3GS and 3G baseband firmware versions, once you are jailbroken using PwnageTool 4.0, install ultrasn0w from Cydia and you’ll be unlocked.
    * Remember! This baseband unlock situation is rare, should you upgrade your iPhone blindly at the next iOS release please don’t expect an unlock - but for now you are OK (whatever state your baseband is in).

    Please feel free to ask any questions in the comment section below. We’ve got a bunch of expert help there, including our friendly moderators confucious and angie!​
    Today, I posted the full guide to Jailbreak iOS 4 on iPhone 3GS using PwangeTool 4.0 but was UnOfficial, Now the Official Release has Came! I will post the guide soon with the new jailbreak tool, but in meantime you can follow the Step by Step Guide posted here that was posted today to Jailbreak your iPhone 3GS on iOS 4.

    Note: After Jailbreaking your Device by the guide posted here, You will be able to Unlock your iPhone 3GS on any Baseband using Ultrasn0w, Full Guide posted here.

    Download PwnageTool 4.0 to Jailbreak iPhone 3GS on iOS 4 [Torrent]
    Download PwnageTool 4.0 to Jailbreak iPhone 3GS on iOS 4 [RapidShare]
     
  2. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    Nice posting to bad uanuglyfool beat you by exactly 1 hour!
     
  3. rev316 macrumors regular

    Joined:
    Nov 7, 2004
    #3
    What's the old bootroom, and new bootroom?

    Versions?
     
  4. appleii2mac macrumors regular

    Joined:
    May 23, 2007
    #4
    And how would I tell which one I have?
     
  5. Jumpie macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #6
    So new bootrom is outta luck? What happens if I tried? Plus, my phone was JB with Spirit.
     
  6. Dextor143 macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #7
    I used spirit but I still have the older boot room. i359.3

    can I still unlock iOS4?
     
  7. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #8
    if you used spirit stay away for now Dev-team has been very clear on this. Think of it as taking two different prescriptions that are great separately but it you take them together bad things happen. ;)
     
  8. XedLos macrumors member

    Joined:
    Dec 6, 2008
    #9
    Can someone clear things up for me. I have a 3gs that i got from apple and i updadet to 3.1.3 and then used spirit. Is there a way to downgrade so i can jailbreak using something other than spirit. I only have the ssh blobs for 3.1.3 and 3.2(for some reason) My boot loader is 359.3
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    No
    Nothing right now.

    Nope, you cant even JB in order to be able to unlock.
     
  10. rev316 macrumors regular

    Joined:
    Nov 7, 2004
    #11
    Well, my "Boot Loader" version is 359.3, no clue if that's "new" or not? Could somebody clear up the version numbers?


    Anyway, tried it with PwnageTool 4.0 on my 3GS, and it wouldn't activate.

    Conclusion: it doesn't work, hold off.
     
  11. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #12
    Old bootrom is 359.3, new bootrom is 359.3.2.

    You need be currently jailbroken with redsn0w, blackra1n, or PwnageTool for PwnageTool to work. If that's the case, please let me know whether you're on an official carrier and whether you unchecked the "activate" box or not?
     
  12. jayeskreezy macrumors 65816

    Joined:
    Mar 3, 2005
    #13
    So I have 3.1.2 on my 3GS and used Pwnage Tool to jb, but after reading that article it said something about waiting until sn0wbreeze is out. Is that the best choice at this point?
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #14
    No, stay away from snowbreeze.
    Stick with Dev team tools.
    They're the best and bug free.
     
  14. bobsegal macrumors newbie

    Joined:
    Jul 24, 2007
    Location:
    Orlando, FL
    #15
    iBook problem

    Jailbreak went ok no errors
    Everything is working excecpt iBook will not down load or open them.
    Tried to sync wit iTunes but comes up blank book case
    Go to re download and have problems with password and never downloads book.

    3GS old boot rom was 3.1.2 before pawnage 4.0 jailbreak
     
  15. rev316 macrumors regular

    Joined:
    Nov 7, 2004
    #16
    Appreciate the clarification. I'm on the official carrier (aka AT&T), and I'm currently on the official 4.0 release.

    What would be the steps for a "functional" JB from here?

    Thanks.
     
  16. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #17
    I don't think it's possible to use Pwnage once you have already installed 4.0

    I tried restoring my iPhone to this custom restore file that Pwnage made for me about 4 times and each time, it failed. I finally gave up and restored back to the unhacked 4.0.

    Hopefully there will be a jailbreak like blackra1n or something soon.
     

Share This Page