Quake 3 Arena Problems

Discussion in 'Mac Apps and Mac App Store' started by gregmac666, Sep 10, 2001.

  1. gregmac666 macrumors newbie

    Jul 3, 2001
    London UK
    Posted this problem at Macfixit.com, but wondered if anyone here could sort this out...

    I have installed OS 9.2.1 with great success (no problems with printers, blah, blah), but I am now finding that Quake 3 Arena is quiting on me with a type 3 Error.

    I manage to launch the game, connect to servers over the internet on my 56k interal G3 modem, but after a matter of time I will have an 'unexpected quit'. Sometimes 30 secs in to the game, sometimes 30 mins.

    I have tried uninstalling the OpenGL drivers after reading that some people have had problems with those, but I can't install the older version 1.2.1 as it asks for OS 9.1 or below to be installed.

    I have tried various memory configs via the 'get info' avenue, but this does not help either.

    This is quite annoying, as I often seem to quit when I am at a crtical moment (i.e carrying the Flag!), and often when a particular part of the map I am playing is very busy with player fragging the hell out of each other. It's like it can't handle all the info around it, and so quits. This never happened under OS 9.1. Ever.

    Any ideas? Would be most please to get back to uninterupted fragging!

    Running a B/W G3 350 DVD with 448MB RAM. Adaptec 2906 SCSI card in place, and Epson 1200 and AGFA Snapscan connected via 4 port USB hub (All working fine).

  2. john123 macrumors 68020


    Jul 20, 2001

    Don't know what machine you're running on...but a lot of games had problems upon starting up under 9.2.1, giving "Could not initialize OpenGL" errors. The fix was to delete all the NVIDIA extensions.

    Try moving all those extensions far away from your system folder....
  3. gregmac666 thread starter macrumors newbie

    Jul 3, 2001
    London UK
    Quake 3 Arena...


    Thanks for the tip, although I believe I have removed the nVidia extensions. I don't get any OpenGL related messages, just that error type 3. Strange.

    Will double check tonight when I get home.

  4. gregmac666 thread starter macrumors newbie

    Jul 3, 2001
    London UK
    Follow-up on Q3A probs..


    Absolutely, possitively no nVidia graphic extensions near my system folders, I don't even think that the OS 9.2.1 updater installed them as my Mac never has had an nVidia card near it.

    I played around a little with the extension. I am finding that with each update to the system, more and more extesions that I would otherwise turn off, I now have to have on.

    An example of this it File Sharing. This may have helped keep me gaming longer last night than any other attempt.

    I disabled 'Proxy App'. What is this? I also disabled something else that had an explanation to do with the classic enviromnent under OS X (which I do not run). Both this and Proxy App had a MAC OS 9.2.1 xtra 1.2 under the 'package' header in the extensions manager. I pressume that as i am not running OS X, that I do not need these. I may look for more.

    I'll keep you posted.

Share This Page