question about updating iphone 3g to ios 4.1

Discussion in 'iPhone Launch Meetups' started by jerkstore01, Oct 1, 2010.

  1. jerkstore01 macrumors newbie

    Joined:
    Oct 29, 2006
    Location:
    new brunswick, canada
    #1
    Hey guys.

    I was looking for some advice. I live in canada, but had my iphone 3g replaced in a apple store in the states when i was there in the summer. Now it's worked fine on 3.1.3 but I wanted to update it to 4.1. The reason I want to do this is because i just got an iphone 4 and want to give the 3g to my wife. I don't want her to have a data plan. There is option in 4.1 to turn off cellular data but in doesn't exist in 3.1.3. So I guess i just don't want to brick the phone. I would assume that it would be unlocked because it's been working for me this whole time. The apple store genius knew that I was from canada. Would you guys think it's safe to upgrade? Thanks in advance for your help.

    -jon
     
  2. iMAVERICKam macrumors member

    Joined:
    Apr 7, 2009
    Location:
    Texas
    #2
    You can safely update; the iTunes activation will still work despite being associated with an Apple ID in different country than purchased/replaced.

    Source: personal experience.
     
  3. projectmk3 macrumors newbie

    Joined:
    Oct 21, 2010
    #3
    id suggest keeping the old version as 4.1 will be too much for the 3g to handle. iv seen too many people with the 3g and everybody with it just complains (iv personally played with plenty 3g running 4.1 and noticed how much worst the phone got)
     
  4. Usual macrumors member

    Joined:
    Aug 10, 2011
    #4
    My suggestion is: Do not do any update and live happy :)

    I hate my Iphone 3g, because it is too slow with the new version. If you try to open Google maps, you need to wait more than a minute sometimes. Or for any other application.

    My suggestion, as a 3G user who has updated his phone and is also regretful, is not to make this change.

    Of course, the advantage is you will be able to download some applications that needs 4.1...
     

Share This Page