Quick Q: "Force Unmount" a Volume?

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by dotnina, Nov 9, 2004.

  1. dotnina macrumors 6502a

    Aug 19, 2004
    A little while ago I installed some software. Days later, the volume still shows up in Finder. Pressing the "eject" button has no effect; I get the error message "Volume could not be found ..." etc.

    So, is there a way to "force unmount" a volume, kinda like how there's a "force quit" for applications?

    Thanks in advance!
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Log Out and Back In and/or Restart... if it's something that's hanging in finder, though sometimes a force quit of the Finder may work.

    Run Disk First Aid and fsck... if it's something that's messed up in the file system.
  3. dotnina thread starter macrumors 6502a

    Aug 19, 2004
    Wow, thanks Sun Baked, that worked! I was starting to panic a little, since I had already restarted a few times, quit Finder, that sort of thing. Disk Utility wouldn't open, either ... but now everything works! It seems the fsck cleaned things up. :)
  4. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Get in a habit of running Disk First Aid/fsck regularly (about once a month) -- should keep the problem/symptom you had from showing up.

    Though most people usually don't bother and end up watching the flashing question mark instead -- the worst end of the problem/symptoms.
  5. abhishekit macrumors 65816


    Nov 6, 2003
    akron , ohio
    Well, the fact that you have to restart it to run fsck makes it a little less appealing as a monthly chore. Though I don't run in every month, but whenever I have to restart due to a software upate (can't remember when was the last time I had to restart for a freeze), I run fsck.

Share This Page