quicksilver733to 1.4 upgrade, been there done that?

fourthtunz

macrumors 65816
Original poster
Jul 23, 2002
1,164
627
Maine
Anybody tried upgrading their quicksilver 733 to a 1.4? I've been trying to get a owc mercury extereme 1.4 to work, this is the 2nd one they've sent and it doesn't work :(
Their tech support just sends an rma and asks you to return it, which I have to pay for shipping each time :mad:
They won't give full refunds, 15% restock fee, so I'd like to get this to work, any ideas?
they say it will work with 9.2.1 and x.2 maybe their wrong
so I thought I would upgrade to 9.2.2 and see if it works, whadya think?
thanks
daniel
 

Lord Blackadder

macrumors G5
May 7, 2004
13,568
2,610
Sod off
I've heard good things about the OWC upgrades, so don't lose heart. It is possible that there is an issue with your computer that is causing trouble, overheating is the most common complaint. Also these upgrades sometimes overwhelm the power supply if you already have a lot of peripherals that may draw extra power (i.e. higher end video cards, multiple hard disks and DVD-RWs)

Try going to 9.2.2, but as with any upgrades your mileage may vary.

Most people get these things to work without trouble but CPU upgrades can get tricky and require a lot of patience sometimes. Good luck.

You've probably heard this suggestion before, but remember that a new Mac mini is only a couple hundred bucks more than that 1.4GHz OWC upgrade....although personally I like my G4 tower.
 

xrays

macrumors member
Jan 6, 2005
31
0
Toronto, ON
fourthtunz said:
Anybody tried upgrading their quicksilver 733 to a 1.4? I've been trying to get a owc mercury extereme 1.4 to work, this is the 2nd one they've sent and it doesn't workl
I upgraded my QS 733 to a Giga 1.467 G4 (bought from OWC) when they were released, which is now about 2 years ago. It's been stable and fast ever since. The extreme heat that we've been experiencing in the North East lately (no A/C at home) has actually over-heated my computer a bit lately, and it's shut down on me 4 times in a month, but I fixed it by using a house fan to get more air near the computer.

I had a few problems when trying to boot into OS-9 in the spring, but realized it was due to trying to boot off a Sonnett Tempo Trio card IDE bus, and it doesn't appear to be supported in 9 for some reason. Once I moved the HD to the built-in IDE bus, everything worked again. I was only booting into OS 9.2.2, and I don't know if anything lower is supported. As for OS-X, I've had no troubles booting into any version of the OS, and no troubles off the Trio card or an S-ATA card (now holding 2x250gig Startup drive).

My first advice to anyone experiencing problems like this would be to strip down your computer to the base components, install the upgrades as per instructed (is there a firmware update required?), and see how far you get. If you're repeatedly getting problems with replacement CPU upgrades, you might want to think about testing the logic board or other components, to verify that they're all operating correctly.

I'd be happy to pass on any more help if you have more questions.

x.
 

krimson

macrumors 65816
xrays said:
I upgraded my QS 733 to a Giga 1.467 G4 (bought from OWC) when they were released, which is now about 2 years ago. It's been stable and fast ever since. The extreme heat that we've been experiencing in the North East lately (no A/C at home) has actually over-heated my computer a bit lately, and it's shut down on me 4 times in a month, but I fixed it by using a house fan to get more air near the computer.

...
i have the 1.33 upgrade, and i've had to leave my door cracked open and a small desk fan blowing in for the last 3 weeks.
 

fourthtunz

macrumors 65816
Original poster
Jul 23, 2002
1,164
627
Maine
Hey guys thanks for the suggestions! I have tried removing the audio cards from the Mac to see if that helped but so far the upgrade still hangs on start but will boot up fine on restart. I don't think that I would feel comfortable keeping the upgrade if it doesn't boot normally. I would get an imac if I didn't need the pci slots for protools and the horsepower for video.
I am getting a G5 at some point but waiting to see what apple has up their sleeve for August/september,thanks for the help!
daniel
 

joecool85

macrumors 65816
Mar 9, 2005
1,355
1
Maine
I'd just get a PM now...they just got updated a while ago. That, and wow do those things move! Power! But thats up to you. Too bad about the upgrade not working for you...I've dealt with enough of that lately. Good luck with it!