iPhone Rare Cydia Error on 5.1.1 JB Continues to Occur After Restore/JB on 6.1-Please Help

Discussion in 'Jailbreaks and iOS Hacks' started by pollybrowne, Feb 5, 2013.

  1. pollybrowne, Feb 5, 2013
    Last edited: Feb 5, 2013

    pollybrowne macrumors member

    pollybrowne

    Joined:
    Nov 4, 2009
    #1
    I started a thread ( http://forums.macrumors.com/showthread.php?t=1527170 ) a couple of weeks ago about a problem I was having with my JB iPhone 4s running 5.1.1 wherein every time I opened Cydia I would get the following error messages:

    Wow, you exceeded the number of package names this APT is capable of.

    Problem with MergeList /var/lib/apt/lists/cydia.winterboarder.com__Packages

    The package lists or status file could not be parsed or opened


    And then when I hit the "return to Cydia" button underneath, I would have the "Welcome to Cydia" home screen etc., but under changes the screen would be completely blank, with nothing listed. And when I'd search for something, nothing would come up.

    Under that thread someone had suggested that I do the following to reset Cydia:

    Navigate to /private/etc/apt/sources.list.d, Delete the file "cydia.list", Navigate to /var/lib/apt/lists, Delete all of the files in this folder except the one called "lock", Navigate to /var/lib/apt/lists/partial, Delete all of the files in this folder, Navigate to /var/lib/cydia, Delete the file "metadata.plist"

    This worked, but then when I started to re-add sources to Cydia, at about the 5/6th source, the same error message/problem occurred again.

    Accordingly, someone suggested I DL iCleaner from Cydia and turn on Cydia clean options. I did this, but did not end up trying to add sources back again because the news about the 6.1 JB came out and I decided I would just wait for that and restore/re-JB which I believed would SURELY eliminate the type of problem I was dealing with.

    However, yesterday I plugged into iTunes, did a full restore to 6.1, then restored from back-up (so I would have my settings/contacts etc.), and jailbroke my phone. Everything went COMPLETELY smoothly. Then last night I was trying to add sources to Cydia and on about the 6/7th source I got the SAME error message about "wow you exceeded...blah, blah, blah"... . I had not installed any packages or tweaks yet.

    Is this something that could have carried over because I restored from back-up after I did the fresh restore? Do I have to restore my phone and set it up as "new" to fix this issue?

    If so, there any other way besides restoring from back-up that I can restore my settings/app data/contacts/notes etc.? (I just have a lot of things that would take ages to re-enter manually--and particularly with application data, I don't even know how I could back that up another way?)

    Or is there some other fix for this that I can try?

    I know this is a long question, and there are a lot of ppl on the boards right now in need of assistance but I would be SO incredibly grateful for any advice anyone could offer on this.

    Thanks!
     
  2. NanoNyrd macrumors regular

    Joined:
    Dec 1, 2011
    #2
    I would try the setup as new phone, I would guess it would work. I would think that if you sync with itunes you get your data back (except old SMSes).

    If it does not work, here is a method for the really desperate:

    1) Restore your phone to 5.1.1 using redsn0w, and rejailbreak.

    2) Purchase PkgBackup. It costs 10$, but isn't your time worth more?

    3) Backup everything you expect to need to Dropbox using PkgBackup. IMPORTANT: Do not back up the Phone app data, it will prevent you from restoring until PkgBackup has been fixed. It prevents me from restoring now, and it is the only thing I cannot disable when restoring because it is maked N/A. :-(

    4) Upgrade to 6.1, jailbreak, resync with iTunes, restore the missing data with PkgBackup.

    NB: I would be tempted to include a point 3A: Wait one week until developers get stuff fixed :)

    Disclaimer: I cannot test this as I backed Phone data up, and this b0rks the restore.
     
  3. pollybrowne thread starter macrumors member

    pollybrowne

    Joined:
    Nov 4, 2009
    #3
    I think the sense of urgency I feel is due to the fact that while I really need to keep my data and settings in place, if it's necessary to let those go, setting up the phone as "new" in order to eliminate this problem with Cydia loading, then that's more important and I'm afraid of Apple throwing an update at us to patch the exploit at any moment and I won't have the option to restore and set-up as "new".

    But maybe I'm just being paranoid?

    On the other hand, if restoring and setting-up as "new" is not the answer for this problem, it's not worth losing all my settings obviously. So I'm just not sure if I should keep trying fixes on the current restore that was from back-up or just do the restore/set-up as "new" immediately...
     
  4. BumpyFlatline, Feb 5, 2013
    Last edited: Feb 5, 2013

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #4
    You can follow my method which I explained here. If you have any questions or concerns just let me know. I've done this many times and know the process like the back of my hands.

    http://forums.macrumors.com/showthread.php?t=1537003

    1) Backup contacts, calendars, reminders, etc with iCloud.
    2) Use AppBackup to backup all your App Store app data like settings and game saves.
    3) DFU Restore as New with your downloaded copy of the ipsw (do not restore from backup)
    4) Set up iCloud on new firmware
    5) Jailbreak with evasi0n
    6) Install all your apps from the App Store
    7) Use AppBackup to restore all the apps to their EXACT state previous to the DFU Restore as New
    8) Enjoy installing packages from Cydia!
     
  5. NanoNyrd macrumors regular

    Joined:
    Dec 1, 2011
    #5
    If setting up as new fails to solve the problem, you can always right-click on your phones name in iTunes, and choose restore from backup.
     
  6. MuGeN PoWeR macrumors 68020

    MuGeN PoWeR

    Joined:
    Jun 29, 2011
    #6
    i got the same problem when i jailbreaked my iPhone 5 and added a source of biteyourapple. after sometime and thoughts i remove the source. and everything got back to normal. so it might be some bad source.
     
  7. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #7
    Turns out this is a limitation(?) of Cydia. Not sure why someone would need so many sources but hey, I'm sure people have their reasons. Anyway, if you are getting this message, "it means you have more than 65,535 packages available from your installed sources, and Cydia cannot handle this many. You need to remove several sources." I got this information from a running evasi0n FAQ on jailbreakqa.com. It's actually very useful. Here's a link....

    http://www.jailbreakqa.com/pages/evasi0n-help
     
  8. brittag macrumors newbie

    Joined:
    Jun 15, 2011
    #8
    Restoring and jailbreaking again won't help, and this isn't related to any particular source being bad. BumpyFlatline is right: this "Wow, you exceeded the number of package names" error message happens because Cydia is currently based on a version of APT that can only support having 65k packages available from your installed sources.

    You can fix the problem by removing some of your sources (by going to Manage -> Sources -> Edit on iPhone/iPod touch or to Sources -> Edit on iPad). That will put the number of available packages below 65k so that you can use Cydia again.

    If some sources seem to not have a "remove" button when you try to remove them, that usually means they were installed as packages. Go to Manage -> Packages on iPhone/iPod touch (or to Installed on iPad), find the package with the source's name, and uninstall that package.

    Keep in mind that pretty much the only way to get to this error message right now is to have several pirate repositories installed (since the default repositories only add up to 41k packages, and legitimate non-default repositories tend to be small). So, to work around this limitation, it's best to uninstall pirate repositories and keep legitimate ones. The default legitimate repositories are BigBoss, Cydia/Telesphoreo, Dev Team, ModMyi, and ZodTTD/MacCiti.
     

Share This Page