Red Alert 3 (and maybe other Cider based games) online play broken in Snow Leopard

Discussion in 'Mac and PC Games' started by bs6mjb, Aug 29, 2009.

  1. bs6mjb macrumors newbie

    Joined:
    Jun 24, 2008
    #1
    Is anyone else having problems playing Red Alert 3 online after upgrading to Snow Leopard, or is it just me?

    I manage to logon but then it disconnects me and says "the registry is corrupt and has been altered"

    It was working nicely before the upgrade and the normal (non online) games plays perfectly.

    Hmmmmm
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #2
    There is definitely something going on with Cider. The Path will run, but my hard disk will go into overdrive, and make the computer beachball up. If I let it be and come back, my free hard drive space withers away to 500 MB (from 30 GB). Bizarre.
     
  3. gavriels macrumors newbie

    Joined:
    Sep 6, 2007
    #3
    I just tried this on Snow Leopard and the game worked fine. My luck in the game was less then stellar, but my ego is happy to chalk that up to trying to play with the trackpad on my MacBook Pro instead of a mouse.

    It's possible that you had some kind of disk corruption on your system that the Snow Leopard install tweaked in some way; since it's overwriting many GB worth of files on your disk, if there was something slightly bad wrong with your filesystem it could have messed things up. It seems very odd that it would have had this effect though. You may want to use Disk Utility to verify your filesystem however.

    It's also possible that it's something happening game side. The error in question has a number of hits on google from PC users.

    In the meantime, you can try to rename the "Command and Conquer - Red Alert 3 Preferences" folder in your ~/Library/Preferences and try again. The Cider equivalent of the registry lives in there , and renaming the folder will force the game to recreate a new fresh preferences folder. You'll need to keep your serial number handy when doing that though.
     
  4. gavriels macrumors newbie

    Joined:
    Sep 6, 2007
    #4
    I just tried The Path (though with a custom build, mildly different from the retail build), and it's running fine here too. Do you know what's taking up all of that disk space? Can you check /var/vm to see if something's growing VM usage in some way? The Activity Monitor might also help you identify where something is eating too much VM.
     
  5. bs6mjb thread starter macrumors newbie

    Joined:
    Jun 24, 2008
    #5
    Thanks for the preferences tip. Thought we might have been onto something there.

    It prompted me for my licence key again and recreated the registry files but unfortunately gave me the same error again. I completely reinstalled snow leopard after emptying the disk with disk utility but the same again.

    I'm wondering if it's some sort of cdkey issue. I'm quite sad and also own the game on PC so that the wife can play me across the LAN and that has no problems

    oh well. Looks like I'll talk to ea

    thanks for the advice though.
     
  6. bs6mjb thread starter macrumors newbie

    Joined:
    Jun 24, 2008
    #6
    Just checking - did you manage to play a game online? Everything on mine works OK except locally. It's only when I try to signon to Gamespy via the star on the top right of the screen that it all goes wrong.

    Thanks

    Matt
     
  7. masterofbuckets macrumors regular

    Joined:
    Apr 24, 2009
    #7
    PC users have also ran into this issue and a reinstall should make it go away.
     
  8. rams macrumors member

    Joined:
    Oct 25, 2004
    Location:
    Switzerland
    #8
    i'm having the same issue.
    i just bought the mac version as digital download and installed it.
    after applying all the patches, it began to start and i entered the activation key.
    next thing i tried was to go online and after i entered the login data, the game simply crashed with a "can not lauch" error and on second try with a exception exception (lol).
    I moved the preferences and now i have the total identical error as described above. it's a fresh install, a new macbook pro - diskutility has no errors, so i'm 100% sure it's a snow leopard problem.

    i hope they will fix it soon :eek:
     
  9. rams macrumors member

    Joined:
    Oct 25, 2004
    Location:
    Switzerland
    #9
    on second thougts: i think the problem is that the game crashes and destroys the registry. that's why there is the same problem as pc users have (since it is a emulation)
     
  10. rams macrumors member

    Joined:
    Oct 25, 2004
    Location:
    Switzerland
    #10
    This is the response i got from the EA Customer support.

    Hello Rams,

    Thank you for contacting EA customer support.

    I apologize for the inconvenience caused to you. There are variety of programs running in the background on your computer which may be using a considerable amount of system resources. Closing these unnecessary background processes will help boost system performance in your game, as well as free up system resources which may be conflicting with the game.

    1. From the Finder menu open the Go menu and select Utilities.

    2. Open the Activity Monitor program.

    3. In the top right cornor, make sure the My Processes option is selected from the pull down menu.

    4. Highlight the programs listed one at a time and click the Quit Process button in the top left.

    5. When the confirmation window appears select Force Quit to close the program.

    6. Repeat those steps until only the following four are listed:

    Dock
    Finder
    LoginWindow
    Activity Monitor

    Note: there will be other programs that either will not close, or will re-appear after being closed. Those processes can be skipped.

    7. Close the activity monitor and attempt to run the game.

    Be aware that this is only a temporary change, restarting the system will restore it to the default state. If closing these programs helps resolve performance issues you may want to go through them one by one to narrow down which program is causing the conflict.

    If the issue still persists please do let us know.

    Thank you,

    EA REP Louis
    EA Online Support.

    ====================================

    of course it didn't help
     
  11. gavriels macrumors newbie

    Joined:
    Sep 6, 2007
    #11
    Workaround here

    I've been able to reproduce this issue, and have a tested workaround.

    The issue can happen if you have a fresh preferences folder (ie: from a fresh user account created on a new Snow Leopard system) when running the latest patched version of the game. For some reason, in this case, the game serial number isn't being written out to the file where Cider stores the equivalent of the game's registry.

    This is possibly the result of some change in a recent patch, as it had been working properly with earlier versions. It's not impossible that this is a Snow Leopard only issue however. We will need to look into this further.

    The workaround is relatively simple:
    - Navigate to ~/Library/Preferences/Command and Conquer - Red Alert 3 Preferences
    - Open the 'system.reg' file using TextEdit
    - At the end of the file, enter the following 2 lines:

    [Software\\Electronic Arts\\Electronic Arts\\Red Alert 3\\ergc] 1234976839
    @="XXXXXXXXXXXXXXXXXXXX"

    (Where XXXXXXXXXXXXXXXXXXXX is your 20 digit/letter serial number, all in upper-case)

    It may also be possible to work around the problem by deleting the game and preferences folder, reinstalling from the original disk or DMG file, then running the game once without patching. I have not tested that approach as yet.
     
  12. rams macrumors member

    Joined:
    Oct 25, 2004
    Location:
    Switzerland
    #12
    Yes, i can confirm that the workaround works. I also agree 100% with your patch theory.

    at least it works now - no more rebooting.

    thank you very much :)
     
  13. bs6mjb thread starter macrumors newbie

    Joined:
    Jun 24, 2008
    #13
    It's fixed it for me too - nice one gavriels!!!

    Thanks

    Matt
     
  14. alkar macrumors regular

    Joined:
    Jan 12, 2008
    #14
    the game is a slideshow fest in Snow Leopard + 8800GT with shaders set to ultra high (like 1 fps) while it was OK (although not smooth either) in Leopard and playable... I can only play this game in Medium settings which look horrible since shaders are set to Medium !

    Any tips ? Any updates that unbreak RA3+ SNow Leo + NVIDIA (I suspect it doesn't affect ATI ?)... Thanks
     
  15. masterofbuckets macrumors regular

    Joined:
    Apr 24, 2009
    #15
    The shaders quality settings is the one which has the biggest impact on performance.

    Ultra high is I think too much to ask to play at very high resolutions. Try playing on 1280 x 720 with all settings high but with shaders set to medium/high.

    That should give 30 fps.

    hope this helps somewhat :eek:
     
  16. alkar macrumors regular

    Joined:
    Jan 12, 2008
    #16
    i'm playing in 1280x1024 but still runs at 1fps if shaders are > Medium.. Didn't do that in Leopard so i guess it's a Snow Leopard incompatbility with this Cider...
     
  17. alam macrumors regular

    alam

    Joined:
    Mar 16, 2008
    Location:
    Saudi Arabia
    #17
    im having the same issue here, every time i play ra3, it's very slow and i set my resolution down to 1024x768, i have gtx 285 mac eddition, i dont know the source of the problem, but when i was playing ra3 on leopard it was ok, now with the snow leopard it sucks :mad:
     

Share This Page