Red line appears down miidle of screen on NEW 21.5 inch Imac...

Discussion in 'iMac' started by Falkie2008, Oct 13, 2010.

  1. Falkie2008 macrumors newbie

    Joined:
    Mar 15, 2008
    #1
    :mad:

    I bought my very FIRST new Imac via a mail order company last Friday.

    The Imac was shipped and I received it on 10-11 and turned it on only to find that there was a very noticeable red line down the middle of the screen above the preview icon ( the dock on the bottom of the screen ).

    I called Apple support and they had me unplug everything and turn it off and wait.

    I did that and still the red line.

    So I took it down to the Apple store and they could still see the red line on the screen as well.

    They also did a quick test and the MRI said there are missing temp sensors.

    They're going to replace the display and send it back to either Cupertino or Elk Grove.

    My question is :

    Is this a common problem ?

    And what are temp sensors ?

    I can't believe I finally got my first New Mac and had it less than 2 hours and this happened.

    By the way, use a cart or handtruck to take this in. I carried it in the box and did something awful to my back.
     
  2. mjsmke macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
    #2
    I wouldn't have accepted a repair on a 2 hour old Mac. I'd want a new one.
     
  3. 87vert macrumors 6502

    87vert

    Joined:
    Oct 7, 2008
    Location:
    Pittsburgh, PA
    #3
    wow... its not that heavy.
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    AFAIK, that's the way it works with online purchases. If you purchase in an Apple Store and there's something wrong with it, Apple will replace it. If you order online (even from the online Apple Store) and something is wrong with it, it's repaired.
     

Share This Page