Red Pill Fix


macrumors 6502
Original poster
Aug 16, 2010
Hey Everyone,

My favorite screensaver is Red Pill, the free Matrix simulator screensaver.

Mountain Lion Broke it. The glyphs appeared to be corrupted.

The dev is kinda pissed at Apple about App Store restrictions (which I understand), and has refused to release an updated version (including on his site, which I don't, but it's his right).

I decided to play around with it to see if I could fix it though.

Looks like doubling the size of the Glyphs graphics file (Glyphs.png) in the screen saver's app package is all you need to do to get it back to working properly on ML. Simply scale the file by 200% and save

I'm not sure if anyone else has pointed this out yet, but I wanted to post it here in case anyone else is a fan too. I won't repost the modified glyphs file because I don't own the copyright to redistribute it, but it is 10 seconds of work in your image editor of choice (including preview) to fix.

To the Dev, if you see this: I'm a fan of your work so if posting this offends you I apologize, but a quick fix like this is nice for a great deal of people that love your screensaver so I am unrepentant in that.
Last edited:


macrumors 68040
Sep 14, 2007
Thanks very much for this, I was annoyed when ML broke it as I've been using it for quite a long while and saw that the dev was not willing to make any updates to it for ML (for understandable reasons after Apple treated him like crap).


macrumors newbie
Aug 26, 2012
redpill screensaver for mountain lion

got mountain lion and was using redpill(matrix) as screensaver.. couldnt make it work,, found mac update website and from there found the above download- redpill(matrix) now works on mountain lion,,, yeah!!!


macrumors newbie
Aug 14, 2013
Thankyou so much for the tip

Hi, I have been a most avid Matrix fan and had been very much annoyed to have found that Mountain Lion had broken the Red Pill.

Thankyou so much for posting the fix. I registered with MacRumors specifically to say this. :)

In Photoshop Elements, I had to first double the Canvas size before scaling it to 200%, then save. Viola, it worked!

(Multicolor Red Pill Screensaver? Over my dead body!!!! Haha... but each to their own. :))
Last edited:


macrumors 6502a
Aug 9, 2006
Does anybody know how I could possibly reprogram this saver?

I simply want to be able to change the color of the glyphs from 'green' to 'red'. From what i've read, I might need to edit the compiled .nib file. And supposedly, there are tricks to do this.

The only files I see within the .saver file are:

-Unix Executable File InfoPlist.strings Matrix.nib a Glyphs.png (its in grayscale, so the color affect must come from programming) A "Matrix.nib" file in a folder entitled "Japanese lproj"

I don't see any other files that I could edit that would let me achieve this, so I am looking for some guidance.


macrumors 6502
Apr 5, 2010
Brighton, UK
Yeah, I realized that as soon as I submitted this post. I was able to figure out how the reprogram the OpenGL generated color array and now all is well. :D

I'm a newbie at programming. Would you be able to either give me step by step instructions about how you did this, or preferably send me a link to the file so I could download your handy work? :D

Many thanks.


macrumors newbie
Dec 13, 2007
Canberra, Australia
Hey Everyone,
Looks like doubling the size of the Glyphs graphics file (Glyphs.png) in the screen saver's app package is all you need to do to get it back to working properly on ML. Simply scale the file by 200% and save
That worked perfectly. Thanks. It had been annoying me for well over a year on ML.


macrumors newbie
Jan 6, 2014
OSX Mavericks

Hey guys, is there a way to fix the Red Pill screensaver on Mavericks? I recently upgraded. The source code symbols used to be clear before but now they're blurry and I think it may be due to the upgrade.


macrumors newbie
Mar 21, 2007
I am also interested in a way to get this fantastic screensaver up and running in Mavericks.


macrumors member
Aug 28, 2014
I apologize for reopening an old thread but I think it's justified.

I'm on Yosemite 10.10.4, and indeed the glyphs for RedPill were off. I just applied seek3r's tip with Preview (just resize up to 200%) and now it's working perfectly.

Thank you.