Red Screen for 1-2 seconds on wake + screen flashing

Discussion in 'macOS High Sierra (10.13)' started by b_scott, Apr 16, 2018.

  1. b_scott macrumors 6502a

    b_scott

    Joined:
    Mar 31, 2008
    #1
    I have a late 2016 MBP with touch bar. When I wake it from sleep the last month or so I get a red screen and then it goes into my desktop. Today I just woke from sleep and the screen flashed over and over and turned dim/bright/dim/off/etc until I held shift/ctrl/command and hit power to reboot.

    Anyone have these issues?
     
  2. dribando macrumors newbie

    Joined:
    Jan 15, 2014
    #2
    Similar issues. BUT, my screen flash is lime green. Very strange. Doesn't hang or effect the wake, just flashes or 0.5 to 1.0 seconds. I'm on 2017 MBP with touch bar running OS 10.13.4. Just noticed it with the latest X.4 update.
     
  3. creativesmith macrumors newbie

    Joined:
    Sep 28, 2011
    #3
    Similar here. 2016 MBP with touch bar.
    Often, but not always, upon waking from deep sleep, the screen displays pink and white "static" for perhaps a second before revealing the desktop. Started seeing this after the update to 10.13.4. First concern was a hardware issue, but am not suspecting it's OS related. Nevertheless, ugh...
     
  4. Painter2002 macrumors member

    Painter2002

    Joined:
    May 9, 2017
    Location:
    Austin, TX
    #4
    My 2017 MBP w/Touchbar 13" has issues with a white snow/static on wake from a long sleep as well. I am in the process of working with Apple to see if this is a software issue, or a more serious hardware issue.

    As a note, do you have any externals plugged in (i.e. external monitors, usb hubs, or other devices) to your MBP? I do know that there were some issues with waking from sleep when you had devices plugged in, but those should have all been fixed with the most recent update.
     
  5. b_scott thread starter macrumors 6502a

    b_scott

    Joined:
    Mar 31, 2008
    #5
    I have nothing plugged in but my apple power plug.
     
  6. CoolMe macrumors member

    Joined:
    Apr 26, 2008
    Location:
    London
    #6
    I get the same thing! Power or no power, its a red/green weird static screen for 0.5-1.0 second and then disappears
     
  7. b_scott thread starter macrumors 6502a

    b_scott

    Joined:
    Mar 31, 2008
    #7
    hoping it's just the current state of OSX and it'll be fixed.
     

Share This Page