Replaced optical bay drive with hdd, now its slow after a month

RDAR

macrumors 6502
Original poster
Oct 23, 2012
259
3
I took out my optical drive and replaced with the stock hdd. It was working fine for a month but now it is so slow. I keep my movie/media files on it. But whenever I go to open stuff now it takes like 30-1min to open and it always stutters. Whenever I seek the movie to another time it takes another 30/60sec until it works again and it continues to stutter. Before it would just open right away and play smoothly. I even took out the hdd again and checked it and made sure everything was installed properly which it was but it is still slow. Is there anyone else who had this problem and would know what to do?
 

Macman45

macrumors G5
Jul 29, 2011
13,196
133
Somewhere Back In The Long Ago
I took out my optical drive and replaced with the stock hdd. It was working fine for a month but now it is so slow. I keep my movie/media files on it. But whenever I go to open stuff now it takes like 30-1min to open and it always stutters. Whenever I seek the movie to another time it takes another 30/60sec until it works again and it continues to stutter. Before it would just open right away and play smoothly. I even took out the hdd again and checked it and made sure everything was installed properly which it was but it is still slow. Is there anyone else who had this problem and would know what to do?
Things to try first, before considering a replacement HDD:

An SMC reset:


http://support.apple.com/kb/HT3964?viewlocale=en_US&locale=en_US



A PRAM Reset:

http://support.apple.com/kb/ht1379


If neither corrects the fault, I'd be looking at the HDD
 

Intelligent

macrumors 6502a
Aug 7, 2013
924
2
I took out my optical drive and replaced with the stock hdd. It was working fine for a month but now it is so slow. I keep my movie/media files on it. But whenever I go to open stuff now it takes like 30-1min to open and it always stutters. Whenever I seek the movie to another time it takes another 30/60sec until it works again and it continues to stutter. Before it would just open right away and play smoothly. I even took out the hdd again and checked it and made sure everything was installed properly which it was but it is still slow. Is there anyone else who had this problem and would know what to do?

You have repaired right?, Reset nvram, i would recommend SSD, but a month is way to little.
 

simonsi

macrumors 601
Jan 3, 2014
4,850
718
Auckland
Full explanation please.

You took out your optical.
You put the stock HDD in the optical bay?
What is in the stock HDD bay?
Where is the OS? (on which drive in which bay)
Where are your data files? (iTunes media etc)
What model MBP do you have?
 

RDAR

macrumors 6502
Original poster
Oct 23, 2012
259
3
Full explanation please.

You took out your optical.
You put the stock HDD in the optical bay?
What is in the stock HDD bay?
Where is the OS? (on which drive in which bay)
Where are your data files? (iTunes media etc)
What model MBP do you have?
I have mid-2012 macbook pro. 2.9 ghz 750gb 8gb ram i7.
I took out the stock 750gb hdd it came with and replaced it with a 240g ssd. Took out the optical drive and put the 750gb hdd there. OSX Mavericks is on the SSD and all my programs are on the ssd. Like I said the only thing on the hdd are movie/media files, nothing more. I run everything through the ssd so it is faster just wanted more memory to place the media files in. Like I said, been using this setup for a month and out of nowhere the hdd will play open files really slow now and videos stutter. Im only talking about videos cause that is the only thing on the hdd nothing else.
 

simonsi

macrumors 601
Jan 3, 2014
4,850
718
Auckland
I have mid-2012 macbook pro. 2.9 ghz 750gb 8gb ram i7.
I took out the stock 750gb hdd it came with and replaced it with a 240g ssd. Took out the optical drive and put the 750gb hdd there. OSX Mavericks is on the SSD and all my programs are on the ssd. Like I said the only thing on the hdd are movie/media files, nothing more. I run everything through the ssd so it is faster just wanted more memory to place the media files in. Like I said, been using this setup for a month and out of nowhere the hdd will play open files really slow now and videos stutter. Im only talking about videos cause that is the only thing on the hdd nothing else.
Cool, now how much free space does each disk have and what are you using to play the movies?

Take a screen shot of CPU activity when the movie is stuttering and post it so we can see what is going on.