Replaced Optical Drive, now Bluetooth not available - Late 2008 Unibody MBP

Discussion in 'MacBook Pro' started by badger15, Oct 22, 2010.

  1. badger15 macrumors newbie

    Joined:
    Oct 22, 2010
    #1
    I just replaced my optical drive with a generic hard drive bay. The drive placed in the bay works just fine and I am booting successfully from it. But now I have no bluetooth?! Where is the adapter located on my machine (late 2008 15" unibody)? I dont feel as though I interrupted anything during my installation other than a clean swap.

    I noticed a gentleman posted the same happenings over at ifixit but an answer has not been posted yet. Ive restarted, shut down, reset SMC, deleted bluetooth pref file...no luck. Bluetooth was working reliably a couple hours ago. Can anyone shed some light for me?

    Thanks!
     
  2. badger15 thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #2
    Where is the adapter on this machine? By the display? What could I have done while swapping the superdrive?
     
  3. ouimetnick macrumors 68020

    ouimetnick

    Joined:
    Aug 28, 2008
    Location:
    Beverly, Massachusetts
    #3
    Did you try and reseat the data cable? The Bluetooth chip is in the display clutch cover, and if that cable is messed up, Bluetooth, WiFi, and the iSight will not work

    [​IMG]
     
  4. badger15 thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #4
    Thanks for the tip ouimetnick, I was having a hard time seating that connector properly. Maybe I damaged something? My iSight and WiFi work, but no bluetooth. I will try to connect it again to see if that helps.
     
  5. badger15 thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #5
    Do you have any tips for putting that data cable in snugly? I could get one side in easily but not the other?
     
  6. ewoo macrumors newbie

    Joined:
    Jan 16, 2008
    #6
    I got the exact same symptoms after installing an SSD in my optical drive bay. I reset my SMC using this procedure: http://support.apple.com/kb/HT3964?viewlocale=en_US

    Now everything is working.
     
  7. millerb7 macrumors 6502a

    Joined:
    Jun 9, 2010
    #7
    Also with the machine flipped over, and the back of the machine away from you... the cluster of wires on the very top left (they are attached to the little bar that you need to slide out of the way to get to the top screw of the optical drive) are bluetooth wires (some at least). At least I was told this about my 2010 uMBP... I'm not sure if it's the same on yours or not... but just make sure you didn't damage any of the wires.
     
  8. tjones2367 macrumors newbie

    Joined:
    Apr 19, 2011
    #8
    Is data cable damaged??

    Hey, did you ever get this issue solved?

    Im actually experiencing the exact same issue when I removed my optical drive.

    Im now looking for a third party that sells that cable. I might have damaged some pins because it did not go in correctly the first couple of times I tried.

    Any clues or hints anyone, I would highly appreciate it. By the way, whats the exact name for this cable? I have a 2009 17"uMBP

    (p.s. I already tried replacing the BT module, so that wasnt it.)

    -Thanks
     
  9. SebastianS macrumors newbie

    Joined:
    Apr 30, 2015
    #9
    Hey,
    i know this thread is a couple of years old, but I got the same problem with my bluetooth (MBP Mid 2010 15") after installing an SSD instead of my optical drive.

    I bought a new bleutooth module and a new flex cable, reset SMC , PRAM nothing helps. Has anybody an idea?
     

Share This Page