Restoring iPhone 4 to iOS 5.0.1 (Preserving Baseband for ultrasn0w)

Discussion in 'Jailbreaks and iOS Hacks' started by raghav2511, Apr 19, 2012.

  1. raghav2511 macrumors member

    Joined:
    Mar 28, 2011
    Location:
    Toronto, ON, Canada
    #1
    Hi All,

    I am using an iPhone 4 with iOS 5.0.1, jailbroken (untethered) and unlocked (ultrasn0w, baseband 01.59).

    The problem for me started 2 days back when my iPhone suddenly lost reception/network. It used to behave similarly in the past, but I used to switch the phone off and switch it back on after a few mins and plug in the SIM and all was well again. But this time, the network didn't come up till the next morning.

    So started googling and found nothing substantially helpful about it. I tried reinstalling ultrasn0w and soft resetting the iPhone (with power + home button) with no luck. I got a little frustrated and started uninstalling packages from Cydia. I uninstalled Corona untether 5.0.1, post which I manually restarted my iPhone and since then it boots up to my lock screen and then restarts within 5 seconds, stuck in a loop. Also my phone started displaying "Searching.." in place of network bars.

    PLEASE NOTE - I already had an UNTETHERED jailbreak so I wasn't dependent on Corona for that, I had installed some package (which I fail to recall) which installed Corona as a part.

    So I knew I had no way out but to completely reinstall iOS 5.0.1. And I forgot that Apple has stopped singing previous versions of iOS. So yet another problem for me!

    I tried creating a Custom IPSW with Pwnage Tool and tried to restore, ended up with error 11 (with TinyUmbrella running in the background and TSS server ON).

    I have googled a bit and found that using iFaith I can get what I want, which is to reinstall iOS 5.0.1 and jailbreak it untethered while preserving my baseband for an unlock using ultrasn0w.

    I found this article on jailbreakqa, which I think will help my do it on my Mac:
    http://www.jailbreakqa.com/questions/32462/frequently-asked-questions#94647

    I was just wondering will this update my baseband if I go through with it ? Do I have any other options ?


    Please help and pardon my lack of technical know-how :)

    Thanks!

    Also TriJetHero posted the following, in which he clearly stated that the baseband will be upgraded.

    In TU advanced tab uncheck set host to cydia, close TU

    For the rest you don't need TU to restore.

    In redsn0w go to Extra's/SHSH blobs/Stitch

    select the stock 5.01 IPSW (download), make sure your phone is unlocked, this will upgrade your BB to 4.11.08 which is unlockable

    redsn0w wil now make a custom IPSW with your SHSH/APticket stitched to it

    Put phone in DFU

    ALT-restore with the custom IPSW

    afterwards jailbreak with redsn0w

    You don't need to restore to get it activated, you can use SAM (repo.bingner.com) to deactivate your phone, when you connect to iTunes it should activated with the congrats message.
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    First of all, to restore to 5.0.1, you must have saved the hash and APTicket files for 5.0.1 (or use iFaith to grab them off your phone now if you can get it into DFU mode)
    You have to make a custom IPSW (because of the preserved baseband)
    Stitch the hash and APTicket files to the custom IPSW
    Use iTunes to restore
    If you get a 1 or -1 error at the end, use Redsn0w to fix recovery

    This might help you
     
  3. raghav2511 thread starter macrumors member

    Joined:
    Mar 28, 2011
    Location:
    Toronto, ON, Canada
    #3
    Thanks for your help, appreciate it! I'll give it a shot and let you know how it goes. I had a confusion though, the PDF mentions that I need to have my Hash File & APTicket from the time when Apple was signing iOS 5.0.1 and that there's no way to do it now, but you suggested otherwise.

    Anyways Redsnow will verify it, so i'll try extracting them now and give it a shot. Thanks!
     
  4. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #4
    Correct me of I'm wrong, but you can grab the Hash/APTicket from your phone while it's on there whether Apple is signing it or not. What you can't do is revert once you're already on a higher firmware w/out these saved from a previous backup.
     
  5. raghav2511 thread starter macrumors member

    Joined:
    Mar 28, 2011
    Location:
    Toronto, ON, Canada
    #5
    Yup, you are right! I just dumped mine. Trying the rest of the process. Fingers crossed!
     
  6. raghav2511 thread starter macrumors member

    Joined:
    Mar 28, 2011
    Location:
    Toronto, ON, Canada
    #6
    Okay! So I am through it!! And it worked!

    Thank you guys for your help, wouldn't have been possible without it :)

    I installed the Custom IPSW as directed and then performed a Jailbreak using Redsnow and then successfully unlocked using ultrasn0w!

    Hope it doesn't get screwed up again.

    FYI- I recall updating "Mobile Substrate" a couple of hours before everything went down. Any thoughts ?
     
  7. akadi macrumors newbie

    Joined:
    May 11, 2012
    #7
    Please Help

    Hi, I have the same problem as with the person who started this thread. Here is some info:

    1) I have a locked iPhone 4. It was running on 4.3.3 before I Upgraded it to 5.0.1 using redsnow to preserve the basbeband 1.59
    2) It was running ok for 3 month, but just today it can't register on the network, and keeps saying "searching"
    3) I want to restore to 5.0.1 while preserving the BB

    here are my questions:
    1)I have the shsh blob saved in tiny umbrella. does that mean the APticket is saved inside the blob as well and i can just stitch it to the custom firmware?


    2)I used ifaith to grab the blob from the phone, but i can't stitch it using redsnow, i get an error saying it can't verify the blob.
    3)i tried stitching the blob using ifaith to the custom NO_BB firmware, but faith said it can't verify the the firmware.

    Please let me know the correct procedure in order to get this right. ALso shall i have the TSS server running while restoring?

    Your prompt response is highly appreciated.

    thanks
     

Share This Page