Return key in Safari Address and Search bar failure?

Discussion in 'macOS High Sierra (10.13)' started by sultanoflondon, Mar 2, 2018.

  1. sultanoflondon macrumors 6502

    Joined:
    Dec 3, 2013
    #1
    Hi all,

    First of all, my return is key working perfectly.

    Secondly, until yesterday, when I would type something in the Safari Address and Search bar and hit the return key, Safari would search the contents of the bar in Google. For some reason, that has stopped working. Whenever I type something in the bar and press return, nothing happens. To search something in Google, I need to use Siri, Spotlight or Google Recommendations in the dropdown menu from the Address and Search bar. This usually means that I need to search Google, in Google, then use that Google page to search for whatever I initially wanted to search for: frustrating and irritating.

    Can anyone help me out? I have tried quitting Safari and this hasn't worked.

    Thank you!
     
  2. amaze1499 macrumors regular

    amaze1499

    Joined:
    Oct 16, 2014
    #2
    based on what you wrote, i would turn off or update all extentions / plug ins. Do you have the same issue with a different user account?
     
  3. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    have you rebooted? (sorry, maybe obvious, but often works...)...
     
  4. sultanoflondon thread starter macrumors 6502

    Joined:
    Dec 3, 2013
    #4
    Turns out the simple fixes in life are the best... well done for the most effective fix ever!
     
  5. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    amazing how often that helps (& how i sometimes forget to try that first, and start intensive troubleshooting)!
     
  6. sultanoflondon thread starter macrumors 6502

    Joined:
    Dec 3, 2013
    #6
    Unfortunately, the issue persists and has returned after a couple of weeks... any thoughts now?

    I must say that the issue is subdued for a couple of hours when I quit & restart Safari.
     
  7. sultanoflondon thread starter macrumors 6502

    Joined:
    Dec 3, 2013
    #8
  8. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #9
    create a 'test' admin account, try using safari there. same issue? this will, at least, tell you if the problem is 'global', or tied to your user account (a preference file, for example)...
     

Share This Page

8 March 2, 2018